
!

! May 21, 2014                                                                                                                                                                     

Tumult Hype 2.5 Documentation



!

!                                                                                                                                                                                           



Overview! 1!                                                                                         
User Interface! 2!                                                                                                                  

Key Terms! 3!                                                                                                                       

Scenes! 4!                                                                                            
Managing Scenes! 4!                                                                                                           

Changing Scenes! 5!                                                                                                           

Rulers! 5!                                                                                                                              

Guides! 5!                                                                                                                             

Elements! 7!                                                                                         
Types of Elements! 7!                                                                                                          

Manipulating Elements! 11!                                                                                                 

Managing Elements! 14!                                                                                                      

Audio & Video! 15!                                                                              
Video! 15!                                                                                                                              

Audio! 16!                                                                                                                             

External Audio & Video (YouTube, Vimeo, SoundCloud)! 18!                                          

Deleting Media! 18!                                                                                                              

Fonts! 19!                                                                                             
Choosing Fonts! 19!                                                                                                            

Adding Fonts! 19!                                                                                                                

Removing Fonts! 22!                                                                                                           

Animations! 23!                                                                                   
Animation User Interface! 23!                                                                                             

Keyframes! 24!                                                                                                                     

Recording! 24!                                                                                                                      

Manually Editing Keyframes! 25!                                                                                        

Motion Paths! 29!                                                                                                                 

Easing and Animation Timing Functions! 29!                                                                   

! �                                                                                                                                                                                          i



Timelines! 31!                                                                                      
Managing Timelines! 31!                                                                                                     

Controlling Timeline Playback! 32!                                                                                    

Looping Timelines! 33!                                                                                                        

Absolute and Relative Keyframes! 33!                                                                               

Actions! 36!                                                                                         
Mouse and Touch Actions! 36!                                                                                           

Scene Actions! 37!                                                                                                               

Timeline Actions! 37!                                                                                                           

Types of Actions! 39!                                                                                                           

Chaining Actions! 40!                                                                                                          

Flexible Layout! 41!                                                                            
Document Scaling! 41!                                                                                                        

Element Pinning and Sizing! 41!                                                                                        

Touch & Mobile! 44!                                                                            
Document Options! 44!                                                                                                       

Scene Touch Actions! 45!                                                                                                   

Element Touch Actions! 45!                                                                                                

Testing! 46!                                                                                                                           

Tips! 46!                                                                                                                                

Hype Reflect! 48!                                                                                 
Connecting to Hype Reflect! 48!                                                                                         

Preview Mode! 49!                                                                                                                

Mirror Mode! 49!                                                                                                                   

More Options! 50!                                                                                                                

FAQ! 50!                                                                                                                                

Previewing & Exporting! 51!                                                              
Preview in a Browser! 51!                                                                                                   

! �                                                                                                                                                                                         ii



Exporting! 51!                                                                                                                       

Hosting Your Document on the Web! 54!                                                                          

Embedding in Other HTML Documents! 54!                                                                      

Dropbox! 55!                                                                                                                         

iBooks! 55!                                                                                                                            

Video and Animated GIF! 55!                                                                                              

Exporting to Other CMSs and Platforms! 56!                                                                    

Document Recovery! 56!                                                                                                     

Resources! 57!                                                                                    
Resource Library! 57!                                                                                                          

Referencing Resources in Code! 60!                                                                                 

JavaScript! 61!                                                                                    
Using JavaScript! 61!                                                                                                          

API Functions! 61!                                                                                                               

API Constants! 63!                                                                                                               

Invoking API from outside of Tumult Hype! 64!                                                                

Inspectors! 66!                                                                                    
Document Inspector! 66!                                                                                                     

Scene Inspector! 68!                                                                                                            

Metrics Inspector! 69!                                                                                                          

Element Inspector! 70!                                                                                                        

Text Inspector! 71!                                                                                                               

Actions Inspector! 72!                                                                                                         

Identity Inspector! 73!                                                                                                          

Keyboard Shortcuts! 74!                                                                    
General! 74!                                                                                                                          

Working with Elements! 74!                                                                                                

Working With Scenes! 76!                                                                                                   

Editing Keyframes! 76!                                                                                                        

! �                                                                                                                                                                                        iii



Editing Animations! 76!                                                                                                       

Editing Motion Paths! 78!                                                                                                    

Using the Inspector! 78!                                                                                                      

Version History! 80!                                                                            
How to Update Tumult Hype! 80!                                                                                        

Tumult Hype Releases! 80!                                                                                                 

Detailed Release Notes! 81                                                                                                

! �                                                                                                                                                                                        iv



!

! �                                                                                                                                                                                         v





Overview 
Tumult Hype is the HTML5 creation app for OS X. Interactive content and animations made with Tumult Hype 

work on desktops, smartphones, and iPads.!

Wow your web visitors by making beautiful animated content with Tumult Hype!!

Tumult Hype is an HTML5 authoring tool. What is commonly referred to as “HTML5” is really a platform of tech-
nologies including the latest HTML tags, CSS styles, and improved JavaScript performance. HTML5’s capabilities 
allow for stunning visual effects and smooth animations, but previously required difficult hand-coding. There were no 
designer-friendly tools for building animated HTML5 content… until Tumult Hype.!

Tumult Hype’s powerful keyframe-based animations bring your content to life. Tumult Hype outputs state-of-the-
art HTML5 that works on all modern browsers and mobile devices like iPhones and iPads. No coding required.!

This user guide will walk you through the entire product and give in-depth details to its workings.!
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User Interface!

Tumult Hype also provides numerous inspectors for manipulating the document, scenes and elements. These 
are discussed in depth in the Inspectors chapter.!
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Key Terms!
There are seven basic key terms to learn for using Tumult Hype: Scenes, Elements, Properties, Keyframes, Ani-

mations, Timelines, and Actions. The remainder of the user guide will reference these terms, and by sticking with 
them you’ll be fluent when conversing with other Tumult Hype users.!

Scenes!
Each Tumult Hype document is composed of one or more scenes. Scenes are analogous to slides in a Keynote 

or PowerPoint presentation, or to cards in HyperCard. Scenes contain elements and timelines. Actions are used to 
transition between different scenes.!

Elements!
Elements are the manipulatable objects in a scene. They can be shapes, text, buttons, textured buttons, images, 

video, HTML widgets.!

Properties!
Properties are the attributes which define an element’s style, positioning, and auxiliary information. Most proper-

ties are animatable. Properties are defined or changed by manipulating elements in Tumult Hype’s scene editor or by 
changing values in an inspector. Properties define, among many things, an element’s location, size, color, borders, or 
the effects applied to the element.!

Keyframes!
Keyframes define a property’s value at a specific time on a timeline.!

Animations!
Animations change a property’s value over a period of time; they are defined by two keyframes that set the start-

ing and ending values of the property’s animation. Tumult Hype automatically creates animations between any 
keyframes which have different values. Animations also have different easing effects, different rates of change, such 
as ease-in, ease-out, ease-in-out, instant, bounce, and linear. Furthermore, by using motion paths, elements can be 
animated along arbitrary complex curves.!

Timelines!
Timelines contain animations. Each scene has a Main Timeline, which is automatically started when the scene is 

shown. Scenes can have many timelines which can play in parallel, and actions are used to control timeline playback.!

Actions!
Actions make your document interactive. Among other things, actions are used to change scenes, control time-

line playback, start or stop sounds, or run custom JavaScript functions. Actions are triggered in response to user 
events, such as mouse clicks or tap gestures, and scene events, such as scene loading or timeline playback comple-
tion. Actions can also be placed on a timeline, to be triggered at a specific time. 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Scenes!
Scenes are a useful way to separate and organize content. They are similar to slides in a Keynote or PowerPoint 

presentation. Scenes contain elements and timelines. Actions are used to transition between different scenes. Each 
scene contains a unique set of elements and timelines; modifying an element or timeline on one scene will not affect 
elements or timelines on other scenes.!

Managing Scenes!
Set the width and height of your document in the Document Size section of the Document inspector. This size 

affects all scenes’ dimensions.!

� !

Tumult Hype’s Scene Selector offers additional control over scenes. Click the Show Scenes toolbar button to 
reveal the Scene Selector. New scenes can be created using the Add Scene button, and the Action menu offers many 
of the commands also found in the Scene menu. Scenes can be rearranged via drag-and-drop, and renamed by dou-
ble-clicking on their name. Finally, scenes can be copied and pasted by selecting a scene in the Scene Selector and 
choosing Edit > Copy and then choosing Edit > Paste.!

� !

Every Tumult Hype document starts with one scene. The Scenes menu offers a few commands for managing 
scenes:!

• New Scene — Creates a new scene and selects the new scene for editing.!
• Duplicate Scene — Creates an identical copy of the current scene, copying all of the current scene’s 

elements, timelines, and animations.!

Setting the scene size

Scene Controls
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• Duplicate Scene (Without Animations) — Creates an identical copy of the current scene, copying all of 
the current scene’s elements, but omitting the current scene’s timelines and animations. This command is 
surprisingly powerful, and is often used to compose complex animations that need to span multiple 
scenes.!

• Delete Scene — Deletes the current scene, removing all associated elements, timelines, and animations.!
• Go To Scene — Offers a submenu listing all of the document’s scenes, and choosing one of the scenes 

makes that the current scene for editing.!
All scenes in a Tumult Hype document are the same size. Change the size of all scenes in a document by open-

ing the Document inspector and either choosing a predefined size from the Default Sizes menu or by entering custom 
dimensions in the text fields below.!

The active scene’s background color is set by the Background color well found in the Color section in the Scene 
inspector. To make the current document transparent and prevent all scenes from drawing their background colors, 
open the Document inspector and deselect the Draw Scene Backgrounds checkbox in the Options section.!

� !

Changing Scenes!
Actions are used to transition between different scenes. Tumult Hype affords ways to trigger actions in response 

to mouse events such as clicks, scene events such as timeline completion, and at specific times. All of those triggers 
can invoke the Jump to Scene… action with one of seven different scene transitions. The Actions chapter has more 
information about all of Tumult Hype’s action triggers and different actions, including the Jump to Scene… action.!

Rulers!
Show the scene ruler by selecting View > Show Ruler, and hide them with the corresponding View > Hide Ruler 

command. When dragging elements, Tumult Hype will show the bounds and midpoint of the selected elements on the 
ruler.!

Guides!
Alignment guides appear and disappear as elements are moved on the scene. Guides assist in arranging ele-

ments relative to each other and the scene. By default, elements snap to nearby guides; this behavior can be dis-
abled by disabling the Snap to Guides command in the Arrange menu.!

The scene and all elements automatically define their own alignment guides. The scene’s automatic guides de-
fine its center and edges. Likewise, every element generates automatic guides for its center and edges.!

Manual guides can be added to the scene, as well. Create manual guides by choosing Arrange > Guides > Add 
Horizontal Guides or Add Vertical Guides. Manually created guides can by dragged anywhere on the scene; drag 
them off the scene to delete them. The Arrange > Guides menu features many commands for showing, hiding, lock-
ing, copying, and pasting guides.!

One very powerful feature in the Arrange > Guides menu is the Add Layout Guides… command. Choosing this 
command reveals a dialog from which guides can be created. From the dialog, you can specify either the number of 

Background Color Property !
(Scene Inspector)
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columns or rows to be created, or the pixel distance between each guide. Layout Guides make arranging content in 
columns or rows a snap.!

�  Layout Guides Dialog
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Elements!
Elements are the objects in a scene. They can be shapes, text, buttons, textured buttons, images, videos or 

HTML widgets.!

Types of Elements!

Text!
Add text to the current scene by choosing the Insert > Text menu item, or by using the Insert Elements… toolbar 

button. The Text inspector allows you to change the selected element’s font, size, style, color, shadow, and spacing.!

For even more styling control, you can directly edit the text element’s inner HTML. Edit an element's inner HTML 
by selecting the element and then choosing Edit > Edit Element’s Inner HTML. In the pop-up window which appears, 
you can enter any HTML and see the results live.!

After inserting a new text element it is selected and editable. When you are done editing press the Escape key or 
click outside the text element. To edit the text at a later point, simply double-click the element. By default, text fields 
automatically expand to accommodate text entered as you type. Manually resizing an element will fix the element at 
the specified size.!

For information on selecting fonts or using web fonts, visit the Fonts chapter.!

Images!
Tumult Hype supports importing a wide variety of web image formats, including JPEG, GIF, PNG, and SVG. Cre-

ate image elements by choosing the Insert > Image… menu item, or via the Insert Elements… toolbar button. You 
can also drag-and-drop images onto the scene, or copy and paste them from other applications. Finally, images can 
be added by dragging-and-dropping from the Media Browser or from the Resource Library (assuming the image is 
already stored in the current document’s Resource Library).!

Images initially preserve their aspect ratio when resized. You can disable this behavior by deselecting the Con-
strain Proportions checkbox in the Metrics inspector. If an image’s dimensions have been changed, the image can be 
restored to its actual dimensions by clicking the Original Size button in the Metrics inspector.!

� !

By default, Tumult Hype documents appear to visitors only after all included images have been downloaded. This 
ensures that scene transitions and animations appear as intended. To disable preloading for individual images, open 
the Resource Library and deselect the Preload checkbox for any images which should not be preloaded.!

!

Proportion and Sizing Options !
(Metrics Inspector)
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Newly created image elements scale the image as the element is resized. If you need an image to repeat hori-
zontally and/or vertically, you can configure those options from the Element inspector’s Background section.!

!
Retina Image Support & Image Optimization: Tumult Hype automatically optimizes images during export; im-

ages are converted to formats supported on the web and resized for optimum support on ‘retina’ screens. For more 
information, please read the Previewing & Exporting chapter. !

� !

To help minimize document size, improve compatibility with all browsers, and improve rendering on high resolu-
tion “retina” displays, Tumult Hype will by default: convert non-web safe images to PNGs or JPEGs, resize images so 
they’re only as large as is needed for the document, and create high resolution “@2x” images that will be downloaded 
by devices with retina displays. Learn more about this feature in the Previewing & Exporting chapter.!

Tumult Hype offers first-class support for “@2x” retina images. As noted earlier, by default, exporting will auto-
matically generate high resolution images whenever possible. When image files are added to the document, Tumult 
Hype intelligently recognizes images whose names end with “@2x” as being high resolution images and adds the 
image to the appropriate resource slot. If both standard and “@2x” images are provided, the “@2x” images are only 
downloaded by desktop browsers and only when viewed on a retina display. At this time, “@2x” images are not sent 
to mobile devices. This is done to ensure that download times remain reasonable even over slow cellular connections 
and to prevent Hype documents from inadvertently using up cellular data quotas.!

Video!
Tumult Hype embeds video using HTML’s native <video> tag, whenever possible. If the browser doesn’t support 

HTML5 video, as is the case with Internet Explorer 6 through 8, Hype falls back to the QuickTime plug-in. For infor-
mation about playing and controlling video, see the Audio & Video documentation chapter.!

Shapes!
You may quickly add a Rectangle, Rounded Rectangle, or an Ellipse from the Elements toolbar item. The Rec-

tangle element is the most foundational element in Tumult Hype: Rectangle elements can be customized to look and 
behave like almost all other elements.!

Add shapes to your scene by selecting Insert > [shape], or by using the Insert Elements… toolbar button.!

� !

Background Property!
(Element Inspector)

Default shapes
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!
Buttons!

Buttons are elements which present different appearances when the mouse hovers over them, or when they are 
clicked or tapped. Tumult Hype offers two pre-configured button types, a flat button and a textured button, in its Insert 
menus. Any element can be converted to a button by choosing Edit > Show Button Controls. Any button element can 
be transformed back into a normal element by choosing Edit > Clear All Button States and then choosing Edit > Hide 
Button Controls.!

� !

When button elements are selected, Tumult Hype shows a segmented control above the element to toggle be-
tween the button’s normal, hover, and pressed states. When the hover or pressed states are active, any changes 
made to the button — including position, size, and background images or gradients — will be applied when the ele-
ment is moused over or clicked. To clear the changes made in those states, choose Edit > Clear All Button States.!

HTML Widgets!
An HTML widget is used to display embedded HTML in your scene or to embed an iframe of a different web 

page. One use for this element is to embed a code snippet that requires its own JavaScript. Insert HTML Widgets 
using the Insert menu or the Insert Elements… toolbar button.!

Button Controls
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To add a Twitter widget, for example:!

1. Insert a new HTML Widget!
2. Open Tumult Hype’s Element inspector!
3. Click the Edit Code Snippet… button!
4. Paste code obtained from Twitter’s developer site into the Inner HTML popover as shown below.!

� !

!
An HTML widget containing Twitter Widget Code
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To display a webpage within the HTML widget, select Specified URL and enter the full URL (make sure to include 
http:// or https://).!

� !

For questions about HTML widgets, please search in our forums.!

Manipulating Elements!

Arrangement, Distribution, and Sizing!
Elements are rearranged and resized using Tumult Hype’s scene editor. To assist with element arrangement, 

Tumult Hype’s scene editor provides automatic guides based on the scene’s border and other existing elements. 
Likewise, it assists with resizing by snapping the element to match the width or height of other elements on the 
scene.!

To quickly rotate elements along the Z-axis, select the elements and press Command key while dragging one of 

the corner resize handles. The �  cursor indicates the selected element will be rotated. The Metrics inspector also 
has controls for rotating elements along the X-, Y-, and Z-axis.!

An element’s anchor point sets the element’s rotation origin. To move a selected element’s anchor point, press-
Command to reveal the anchor point crosshair icon �  and then drag the icon to a new location. The Metrics inspector 
offers control over the anchor point location in the Rotation Origin section.!

!
Please note that an element’s anchor point cannot be modified if it’s animated using motion paths.!

Multiple elements can be moved, rotated, or resized by first drag selecting elements on the scene and then mov-
ing or resizing one of the selected elements.!

The Arrange menu also has several different commands for arranging, distributing, and resizing elements:!

• Distribute > Horizontally!

Display a Web Page within an HTML widget
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• Distribute > Vertically!
• Distribute > Horizontally Within Selection!
• Distribute > Vertically Within Selection!
• Align > Left!
• Align > Center!
• Align > Right!
• Align > Top!
• Align > Middle!
• Align > Bottom!
• Size > Make Same Width!
• Size > Make Same Height!
• Size > Make Same Size!

CSS Filter Effects!
CSS Filter Effects offer control over the following effects: blur, sepia, saturate, hue, brightness, and contrast. All 

Filter Effects can be animated. Note that these effects are only supported in Chrome 18+, Safari 6+, and iOS 6+.!

� !

 Z-Ordering!
The stack order of elements can be changed by choosing Bring Forward, Bring to Front, Send Backward, or 

Send to Back from the Arrange menu, clicking the Front or Back toolbar buttons, or by reordering elements in the 
Element List.!

� !

Element Inspector: CSS Filter Effects

Ordering Toolbar Items
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Identity!
The Identity inspector provides access to less common element properties, such as the alt tag, a modifiable ele-

ment ID, and the display name used within Tumult Hype.!

� !

Inner HTML!
Elements are, at their base, HTML divs. Because of this, they can contain arbitrary HTML. Edit any element’s 

inner HTML of any element by choosing Edit > Edit Element’s Inner HTML. This is useful for pasting your own custom 
HTML or CSS, or for tweaking text displayed in elements. Keep in mind that if recording is turned on, modifications to 
an element’s inner HTML will be animated.!

� !

The Identity inspector for a selected image.

Editing the Inner HTML of a Rectangle
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Managing Elements!

Grouping!
Elements can be grouped by selecting one or more elements, then clicking the Group toolbar button. Grouped 

items appear indented under their group’s name in the Element List. Clever uses of grouping include enables crop-
ping or masking, rotation from a specified point, and rotation on multiple axes.!

� !

Elements can be dragged in or out of groups by rearranging elements in the Element List.!

Hiding and Locking Elements!
Locked elements cannot be selected or moved on the scene, and their properties cannot be changed in the in-

spector. Hidden elements are not visible on the scene and are also not exported. Multiple elements can be locked or 
hidden at the same time by selecting multiple elements on the scene or in the Element List and then choosing 
Arrange > Lock or Arrange > Hide.!

Elements and groups both can be locked or hidden. Any adjustment to locking or visibility on a group affects the 
state of elements within it.!

Each element’s visibility and locking buttons now support modifier keys for toggling their state en masse. If you 
Command-click on an element’s visibility or lock button, all other elements will match the clicked element’s state. Op-
tion-clicking will change all other elements’ state, so you can easily hide or lock all other elements.!

!

Grouping Toolbar Buttons
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Audio & Video!
Tumult Hype supports the latest HTML5 video and audio standards, and gives you the tools to create rich multi-

media documents.!

Video!
Tumult Hype embeds video using HTML’s native <video> tag, whenever possible. If the browser doesn’t support 

HTML5 video, as is the case with Internet Explorer 6 through 8, Hype falls back to the QuickTime plug-in.!

Adding Video!
Add video elements by choosing Insert > Video…, or by clicking the Insert Elements… toolbar button and choos-

ing Video…. You can also drag-and-drop videos onto the scene, or copy and paste them from other applications. Tu-
mult Hype supports importing files with .mov, .ogg, .ogv, .webm, .mp4, and .m4v extensions, though only .mov, .mp4, 
and .m4v files can be viewed from within Tumult Hype.!

Browser Support!
Unfortunately, the current state of HTML5 video is quite fractured. Safari and Internet Explorer support H.264 

(.mp4 and .m4v files), while Firefox supports Theora (.ogg and .ogv files), and Chrome supports H.264, Theora, and 
VP8 (.webm files). Luckily, the video tag supports multiple sources for one element. Adding a single video in Tumult 
Hype creates a video group to which other formats may be added. To add additional video formats, select your video 
and click Add Video Source in the Resource Library, or select your video and add your source in the Element inspec-
tor.!

To convert videos into these formats, we recommend using Miro Video Converter. It is simple, effective, and free. 
Instructions on how to use this software are at diveintohtml5.info/video.html.!
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Controlling Video!
The Element inspector exposes options for the selected video:!

• Autoplay — Video will play when it is shown (see compatibility note below).!
• Controls — When checked, video controls are shown.!
• Loop — Video will loop when complete!
• Muted — Audio will not play for the video.!

� !

Compatibility Notes!
• iOS: Video will not play on iOS devices without user interaction. Thus, videos played ‘On Scene Load’, ‘On 

Scene Unload’, or using a timeline action will not play back on iPhones, iPads, or iPod touches. Use Mouse 
Click actions to play video on iOS.!

• iBooks Author: Ensure that your video files do not contain spaces or foreign characters in their filenames.!

Video FAQs!
• Embedding an external video, embedding YouTube Videos, and removing videos when leaving the scene.!
• How do I create custom play or pause buttons?!
• How do I embed a YouTube or Vimeo video?!
• How do I place a video within an iBooks Author widget?!
• How do I stop a YouTube or Vimeo video when leaving the scene?!
• Why isn't my video playing in Firefox?!

Audio!
On the newest browsers, Tumult Hype plays audio using the powerful Web Audio API. On less recent browsers, 

Hype falls back to the standard <audio> tag. On old browsers like Internet Explorer 6 through 8, Hype relies on the 
QuickTime plug-in.!

Adding Audio!
To add audio to your project, first create your file formats. For example, prepare the files: whalesounds.mp3, 

whalesounds.ogg and whalesounds.wav. Dragging these files into the resource library will create an audio source 

Video Sources and Options!
(Element Inspector)
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group called ‘whalesounds’. You can also individually add audio formats by selecting the audio source group and 
adding missing formats.!

The image below illustrates an audio group named “whalesounds” in the Resource Library.!

� !

Browser Support!
For broad browser compatibility, we recommend supplying MP3 and OGG files for each audio group. One audio 

source group may contain any combination of MP3, OGG, or WAV files. We recommend converting between the var-
ious audio formats using Miro Video Converter. For generating other audio formats, we recommend Audacity.!

Controlling Audio!
Once an audio source group exists in your document, audio can be played or stopped using scene, mouse/

touch, or timeline action handlers. The Play Sound… and Stop Sound… actions can be invoked by any action han-
dler, and those actions let you choose from any of your document’s audio groups. When playing audio, the Loop op-
tion continuously plays the chosen audio group  in a loop. Likewise, the Preload option controls whether the audio 
group’s files should be downloaded before your Hype animation begins playing. For a list of all available actions, see 
the Actions chapter. Below are a few examples of how actions can control audio playback:!

• Start audio when a scene begins by adding an On Scene Load action handler and then choosing the Play 
Sound… action.!

• Start audio after clicking or tapping an element by adding an On Mouse Click (Tap) action handler to the 
element, and then choosing the Play Sound… action.!

• Start audio three seconds after the beginning of a timeline by adding timeline action to the timeline, and 
have the timeline action invoke Play Sound….!

• Stop audio when exiting a scene by adding an On Scene Unload action handler and then choosing the 
Stop Sound… action.!

If you are interested in controlling audio with JavaScript, or referencing audio files hosted externally, please read 
Playing and Controlling Audio with JavaScript. !

Audio Sources (Resource Manager)
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� !

!
Compatibility Notes!
• iOS: Audio will not play on iOS devices without user interaction. Thus, audio played ‘On Scene Load’, ‘On Scene 

Unload’, or using a timeline action will not play back on iPhones, iPads, or iPod touches. Use Mouse Click actions 
to play audio on iOS.!

• iBooks Author: Ensure that your audio files do not contain spaces or foreign characters in their filenames.!

External Audio & Video (YouTube, Vimeo, SoundCloud)!
To embed external media such as a YouTube video or SoundCloud player, use an HTML widget. Select Insert > 

HTML Widget, and select the Element inspector. In the HTML Widget area, click Edit Code Snippet… and paste your 
embed code in the Inner HTML area. For more information about embedding videos, read our YouTube & Vimeo 
knowledge base article.!

Deleting Media!
Audio and video added to your Tumult Hype document appears in the Resource Library. To delete media, select 

it, and click the Minus button.!

!

Audio played by a Timeline Action
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Fonts!
Text is central to almost every document, and Tumult Hype offers powerful tools for styling text. Tumult Hype’s 

Text inspector contains numerous options for customizing text. Change text size, styling, shadows and spacing. Hype 
also allows you to choose from a set of Web- or iOS-safe fonts, or to even add Web fonts from Google’s Font Directo-
ry or from your own curated web font collection.!

Choosing Fonts!
Changing the font for selected text is as simple as clicking a font’s name in the Text inspector. By default, Tumult 

Hype offers a set of fonts that are considered “Web safe” and work on a broad array of browsers, as well as a set of 
fonts available on all iOS devices. Furthermore, you can add fonts from the diverse and free set of web fonts offered 
by Google’s Font Directory. You can even add your own CSS Web fonts should you have your own set of curated 
fonts.!

Select from the Web, iOS, Google, or Custom font family selection menu to choose different fonts.!

� !

Adding Fonts!
In addition to the default fonts available in Hype’s Text inspector, you can add fonts to your document by choos-

ing fonts from Google’s Web Fonts library, by adding code provided by a 3rd party Web font service, or by adding 
your own @font-face CSS styles.!

Adding Fonts From Google’s Font Directory!
Google’s Font Directory contains hundreds of royalty free web fonts hosted on Google’s servers. Adding Google 

Web Fonts to your document is incredibly simple with Tumult Hype:!

!
Font Family Selection
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1. Click the Add More Fonts button in the Text inspector.!
2. Choose a font from the list of Google Fonts.!
3. Choose a font weight (if applicable).!
4. Click Add Font.!

To use your newly added Google Web Font, select text or an element containing text, and then choose the font 
from Hype’s font list. You can filter the font list to include just Google Web Fonts by choosing Google Fonts from the 
filter menu above the font family listing.!

� !

Compatibility Note!
• iOS: Google Fonts require a network connection. If you check ‘Create offline application cache’ in the document 

inspector, offline users will receive a network error if they haven't yet launched your web app. If they have launched 
the web app, text using Google Fonts will appear in a fallback font.!

!
Third Party Services!

Third party services such as Typekit can be added to the Text inspector’s Font Family list by using the Add More 
Fonts button in the Text inspector. Many third party libraries require a snippet of code to be placed in the <head>...</
head> area of your exported .html file. This knowledgebase article illustrates this process for services like Typekit and 
Font Awesome. The general steps are:!

!
Adding a Google Font
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1. In the Text inspector, click Add More Fonts.!
2. From the Source drop down menu, choose Custom CSS.!
3. Add a descriptive name for your font in the Display Name field.!
4. In the CSS Font-Family field, add your CSS font-family name.!
5. Based on instructions from your Web font provider, paste any code required into the Embedded Head 

HTML field.!
6. Click Add Font. Your font is now listed in the Text inspector’s Font Family list.!!

Troubleshooting: If your font fails to display when editing within Tumult Hype, you may need to add 'localhost' to 
your list of approved domains. Here are instructions for Typekit, and instructions for Fonts.com.!

The below example shows a sample embed code for Typekit. Typekit excludes a protocol from their javascript 
reference to ensure that the font files are served over https and http:!

<script type="text/javascript" src="//use.typekit.net/xxxxxx.js"></script> 
<script type="text/javascript">try{Typekit.load();}catch(e){}</script> !

Since Typekit doesn't provide a protocol, your font may not work when previewing on your computer or a local 
network. You may need to replace!

//use.typekit.net/xxxxxx.js !
with!

http://use.typekit.net/xxxxxx.js !
to fix this.!

Declaring a @font-face style!
If you have your own custom web fonts not hosted on other services, add them to Hype by following these steps:!

1. Prepare your CSS defining your custom font face. Our CSS example below loads a set of Futura Bold 
font files, and links those files to the font family FuturaTOTBold, with Arial and Helvetica as fallbacks:!

<style> 
    @font-face { 
        font-family: 'FuturaTOTBold', Arial, Helvetica; 
        src: url('${resourcesFolderName}/futuratot-bol-webfont.eot?#iefix') 
format('embedded-opentype'), 
        url('${resourcesFolderName}/futuratot-bol-webfont.woff') format('woff'), 
        url('${resourcesFolderName}/futuratot-bol-webfont.ttf') format('truetype'), 
        url('${resourcesFolderName}/futuratot-bol-webfont.svg#FuturaTOTBold') 
format('svg'); 
    } 
</style> 

For information regarding this CSS, please see this article on Fontspring.!
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2. Click the Resource Library toolbar icon and drag-and-drop each of the font files referenced in the CSS 
into the Resource Library. For the broadest compatibility, font sets should include the following formats: !

futuratot-bol-webfont.eot 
futuratot-bol-webfont.woff 
futuratot-bol-webfont.ttf 
futuratot-bol-webfont.svg 

3. In the Text inspector, click Add More Fonts.!
4. From the Source drop down menu, choose Custom CSS.!
5. Add a descriptive name for your font in the Display Name field.!
6. In the CSS Font-Family field, add your CSS font-family name. Font providers set this name, and typical-

ly offer fallbacks as well. For our example, the Font-Family name is 'FuturaTOTBold', Helvetica, Arial.!
7. Paste the CSS code prepared above into the Embedded Head HTML field.!
8. Click Add Font. Your font is now listed in the Text inspector’s Font Family list.!

Removing Fonts!
Custom fonts and Google Web Fonts added to your document appear in the document’s Resource Library. To 

remove a font, choose it in the Resource Library click the Minus button. If you have added font files (e.g. .otf or .ttf 
files) you should also remove those from the Resource Library.!

!
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Animations!
Tumult Hype uses a powerful keyframe-based animation system to give elements motion and transitions. Its 

recording functionality makes building animations a snap.!

Animation User Interface!

1. Animation controls (left-to-right): Jump to Start, Previous Frame, Next Frame, Play/Pause, Loop!
2. Current time indicator; matches playhead!
3. Record Button!
4. Timeline Selector Popup Menu!
5. Playhead!
6. Animatable Property Popup Menu!
7. Timing Function Popup Menu!
8. Add Keyframe Buttons!
9. Time scale zoom slider!
10. Timeline View with Animation!
11. Timeline Action!
12. Motion Path Toggle Button!!
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Keyframes!
Keyframes specify the value for a property at a specific point in time, and animations are composed of two 

keyframes which define the starting and ending values of a property’s animation.!

� !

In traditional hand-drawn animation, creating frames is split between two groups of people: keyframe artists and 
in-betweeners. The keyframe artists would draw the most significant frames, usually where shifts in action would oc-
cur. If they were animating a bouncing ball, they might draw two frames: the top of the bounce and when the ball hits 
the ground. The in-betweener would do the more tedious work of drawing the intermediate frames to bring the ball to 
life.!

You are the keyframe artist when using Tumult Hype. You can specify keyframes for element properties on the 
timeline and Tumult Hype will automatically generate the in-between frames for you.!

Recording!
Recording is an intuitive way to automatically generate keyframes when creating animations. Simply click the 

Record button, move the playhead, and manipulate elements on the scene or change properties in the inspector. In 
response to your actions, Tumult Hype creates the necessary keyframes on the current timeline. Recording elimi-
nates the need to manually insert keyframes.!

Create an animation of an element moving over three seconds by following these steps:!

1. Click the Record button to turn on recording!
2. Select an element to animate!
3. Move the playhead to the right and stop at the 3 second tick mark!
4. Drag an element to a new location, or resize an element.!

Notice a red animation bar was created on the timeline. The red animation bar may be moved to change the start 
and end time of the animation. Click and drag the beginning or ending point of this bar to adjust an animations' timing.!

!
Animation Keyframes
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The Capo!
The Capo pairs with Tumult Hype’s recording feature to let you quickly build animations which start and end at 

arbitrary times without manually inserting keyframes. With Recording enabled, you’ll see a small tab — the Capo — 
appear at the left edge of the time scale area.!

� !

The position of the Capo sets the starting time for your animation. The Capo and playhead are typically moved 
independently from each other, and you can adjust the position of both simultaneously by holding the control button 
while dragging either. By default, the Capo snaps to second markers and other keyframes when dragged. Disable this 
behavior by deselecting the Animation > Snap to Seconds or Animation > Snap to Keyframes menu items.!

� !

Recording and the Capo are incredibly powerful animation tools. With them in your arsenal, you’ll rarely need to 
manually insert keyframes for individual properties.!

Manually Editing Keyframes!

Adding Keyframes!
Keyframes operate on specific properties. An animation requires two keyframes: a starting keyframe and an end-

ing keyframe. The in-between frames are automatically formed and will smoothly transition the property value from 
the start to the end.!

To add a starting keyframe, select an element in the scene editor. Your selected element will also appear high-
lighted in the element list below the scene area. In the property list below the element, you can select a specific prop-
erty that you want to animate. For example, if you wanted an object to fade in, you would select the opacity property. 
Next, you can move the playhead to where you want the animation to begin. Click the Add Keyframe button. This will 
visibly place a keyframe on the timeline. At this point, you’ll set the value of the property you want to animate. For the 
fade in, you would go to the Element inspector and set the opacity value to 0%.!

!
Capo Tab

!
An Animation Created Using Recording and the Capo
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To add the ending keyframe, move the playhead to the point on the timeline you’d like the animation to end at. 
Click the Add Keyframe button again to create a second keyframe on the timeline. Finally, you’ll want to set the prop-
erty to its ending value. To complete the fade in, set the opacity to 100%. A bar between the keyframes will appear; 
this indicates the property is animating.!

� !

By default, clicking a property’s Add Keyframe button adds a keyframe for the associated property at the play-
head’s current time. Option-clicking the Add Keyframe button adds keyframes for all visible properties in the proper-
ties list. 

!
Per-Property Add Keyframe Buttons

Tumult Hype 2.5 Documentation! �                                                                                                                                   26



Setting Keyframes on Any Property!
By default, when you click on an element in the element list the only properties that are shown in the properties 

list are the opacity, origin, and size. These are the properties you’ll likely be manipulating, but Tumult Hype is capable 
of animating most properties you can set in the inspector. To manually add keyframes for other properties, you’ll need 
to add them to the currently selected element’s property list. To do this, click on the Properties pop-down menu and 
select which property you’d like to animate. Now this property can be selected for adding keyframes.!

� !!
If you are recording, Tumult Hype automatically adds properties to the properties list as you manipulate elements 

on the scene or change values in the inspector.!

Modifying Properties!
For manipulating properties with keyframes, there are two rules to note:!

1. If the playhead is on a keyframe for a property and that property is manipulated through the inspector, 
the keyframe value itself will change.!

�  !
 

 
 

!
Animation Keyframes

Playhead on Keyframe
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!
2. If the playhead is not directly on a keyframe for a property that has keyframes, and the property is 

changed, then the keyframes will all be offset.!

� !

These rules are best illustrated by considering an example involving an animation of an element’s Origin (Left) 
property. The animation is defined by two keyframes: one placed at the 1 second mark with a value of 10px, and a 
second at the 2 second mark with a value of 20px. With those keyframes, the animation will start at 1 second and, 
over a full second, will move the element to the right by 10 pixels until it reaches the ending keyframe’s value of 20px.!

With this animation, placing the playhead at either 1 second or 2 seconds will allow you to modify the value of 
those two Origin (Left) keyframes; any changes made to the element’s Origin (Left) value when the playhead is over 
those keyframes will change the value of those keyframes and thus change the distance the element will move. Con-
versely, when the playhead is at any other time on the timeline, changing the element’s Origin (Left) property will 
change the location of the element itself; the starting and ending points of the animation will change, but the actual 
animation itself is unchanged.!

Manipulating Keyframes and Animations!
Keyframes support most standard manipulations; multiple keyframes can be selected, dragged to move, copied, 

and pasted. While keyframes are represented by diamonds in the property area, the duration and span of animations 
are represented by the bars between keyframes. To the right of the elements are animation overview bars, which 
represent keyframes as white lines. These bars can be resized and dragged to adjust animations. They can also be 
multiply selected, copied and pasted, just as with keyframes.!

� !

By default, the playhead, keyframes, and animations snap to second markers and other keyframes when 
dragged. Disable this behavior by deselecting the Animation > Snap to Seconds or Animation > Snap to Keyframes 
menu items.!

Delete both keyframes and animations by drag selecting them in the timeline view and then pressing Delete. 
When adjacent keyframes are deleted, the animation between those keyframes is also deleted. Deleting an element-
level animation overview bar will delete all associated property animations.!

Copying and Pasting Animations!
To duplicate an element and its animations, first select the element on the scene or in the element list, then se-

lect Edit > Copy, and finally select Edit > Paste with Animations. Keyframes and animations can also be copied from 
and pasted to the timeline.!

Playhead off Keyframe

Animation Overview Bar and Keyframe indicators
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Motion Paths!
Elements can be animated along complex and arbitrary curves using motion paths.!

Creating a Motion Path!
A motion path is a curved animation between two or more points. Create a motion path by first creating a basic 

animation between two points.!

1. Click the Record button to turn on recording.!
2. Advance the playhead to your animation’s desired ending time.!
3. Move the element to the desired ending location.!
4. Turn off recording by once again clicking the Record button.!

Now that there’s an animation, convert the basic path to a motion path by first clicking on the animation’s path to 
select it for editing, and then clicking once again to add a motion path control point. Dragging the control point or the 
control handles alters the curve, and additional control points can be added anywhere on the path by clicking the 
path.!

Motion paths unify Origin (Top) and Origin (Left) properties under one single Origin (Motion Path) property, be-
cause the motion path itself controls the top and left position of the element. As a result, Tumult Hype warns you if 
you attempt to convert a linear animation with different timing functions for Origin (Top) and Origin (Left), because the 
new motion path can only support one timing function.!

Furthermore, converting an element to use motion paths will change all of that element’s animations on all time-
lines to use motion paths. To preserve standard animations in different timelines, create a copy of your element by 
selecting your element and choosing Edit > Copy and then choosing Edit > Paste with Animations.!

By default, elements move along motion paths without rotating. When the ‘Rotation follows motion path’ option in 
the Metrics inspector is enabled, elements instead rotate so they’re always perpendicular with respect to their motion 
path with their right edge forward. If your right edge is not the "front" of the image you may need to rotate your ele-
ment on the Z axis so that the correct edge is on the right side. For example if your object is moving from right to left 
you will likely need to rotate your image by 180 degrees.!

Adjusting a Motion Path!
• Shape: To adjust a motion path’s curve, click once on the path and then click and drag any control point to 

change it’s location, or any control handles to change the nature of the curve.!
• Adding and Removing Control Points: Add control points by first selecting a path; once a path is selected, 

clicking anywhere on the path will add a control point. This cursor indicates a control point will be added 

when the path is clicked: � .  
Any control point can be removed by clicking on the control point and then pressing Delete. Because the 
starting and ending control points define the element’s animation, those can only be deleted by deleting 
the animation itself as is described in the Manipulating Keyframes section.!

• Rotation: By default, elements move along motion paths without rotating. When the “Rotation follows mo-
tion path” option in the Metrics inspector is enabled, elements instead rotate so they’re always perpendic-
ular with respect to their motion path.!

For more precise control over Motion Paths, view available keyboard shortcuts.!

Easing and Animation Timing Functions!
By default, animations use the Ease In Ease Out timing function. Ease-in-out smooths the beginning and ending 

movements of an animation so that changes slowly accelerate and then decelerate. To change an animation’s easing, 
click the animation bar between any two keyframes, then choose a different timing function from the Easing menu on 
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the right side of the Timeline view. You can also double-click any animation bar to reveal an animation pop-up which 
features the same Easing menu.!

Tumult Hype supports the following animation timing functions:!

• Instant – The property jumps to the value of the ending keyframe, at the time of the ending keyframe.!
• Linear – Constant steady change between the starting and ending keyframe values.!
• Ease In – Constantly accelerates from the starting keyframe value towards the ending keyframe value.!
• Ease Out – Constantly decelerates from the starting keyframe value towards the ending keyframe value.!
• Ease In Ease Out (Default) – Accelerates change during first half of the animation; decelerates change 

during the second half.!
• Bounce – The property's quickly changes towards the ending keyframe’s value, then “bounces” off that 

value twice. Often used for creating natural vertical bouncing animations, by applying this timing function 
to an animation of an element’s Top property.!

� !

!
!

Animation Properties pop-up and Easing menu
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Timelines!
Timelines contain animations. Each scene has at least one timeline known as the Main Timeline whose playback 

is started when the scene is first loaded. Scenes can have many timelines, and using actions to start, pause, or con-
tinue timelines creates rich and complex documents.!

Managing Timelines!
There are three ways to create timelines:!

Timeline Selector Menu!
Timelines can be added via the Timeline Selector pop-down menu by clicking on the menu and choosing the 

New Timeline… command. Newly created timelines are automatically selected for editing.!

� !

Timeline Selector Menu!
Timelines can be created when choosing Start Timeline…, Pause Timeline…, Continue Timeline…, or Go to 

Time in Timeline… as an action handler. (The Actions chapter has more information about Tumult Hype’s various 
action handlers.) Choosing one of those actions presents a Timeline pop-up menu, and choosing New Timeline… will 
create a timeline.!

!
!

Action Handler Menus
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Scene Inspector!
Timelines can be added in the Scene Inspector’s Animation Timelines section. Click the Plus button to add a new 

timeline.!

� !

Timelines can also be removed and modified in the Animation Timelines section. Double-click on a timeline name 
to rename it, and click the Minus button to delete the selected timeline.!

Controlling Timeline Playback!
Animations on the Main Timeline run when the scene is first loaded. Additional timelines act as containers for 

animations that use elements in the scene, but are not to be run when first loading a scene. (It is possible to have 
additional timelines run when a scene is loaded: create an On Scene Load action handler that invokes Play Time-
line… for one or more alternate timelines.) Switch between different timelines by using the Timeline Selector menu.!

Timelines can also be controlled by the On Drag action handler at either the scene or element level. This tech-
nique is useful for giving users control over “scrubbing” timelines, or for building complex drag animations.!

� !

Animations on the Main Timeline are started automatically when a scene is loaded. Actions are used to control 
playback of both the Main Timeline and alternate timelines. Please see the Actions chapter for more information.!

Animation Timelines Properties in the Scene Inspector

Timeline Selector Menu
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Timeline Playback Direction!
Timelines may be played either forwards or backwards. By default, a timeline plays forwards and only once.!

To play a timeline in the opposite direction, select ‘Play in reverse‘. To start a timeline from its ending point, cre-
ate a 'Start Timeline' action, and check 'Play in reverse.' To play a timeline in reverse at the end of its animation, use a 
timeline action to Continue Timeline… and check Play in reverse as shown below:!

!

Timeline Playback Example!
Download a Hype document demonstrating various timeline concepts.!

Looping Timelines!
An easy way to loop timelines is to add a Timeline Action at the end of the timeline that will run a Start Timeline 

action on the current timeline.!

If you want a timeline to oscillate (play forward and then in reverse) add a Continue Timeline action with the Play 
in reverse option checked at the end of the timeline. To loop this you can also add a Continue Timeline forward action 
at the beginning of the timeline. The document below demonstrates oscillating timelines and looped timelines. !

(Download example document)!

Note: Generally it is better to use Continue to change the direction of a timeline, only use Start in reverse if you 
want to jump to the end and play in reverse. Using Continue Timeline to change the direction will only play the actions 
in that action chain once and then will continue in the opposite direction. However if you use a Start Timeline action 
the timeline will complete all actions chained with this action and then start over from the end playing all actions in the 
chain a second time before continuing in reverse.!

Absolute and Relative Keyframes!
Timelines contain starting keyframes that are either absolute or relative. By default, all timelines are created with 

absolute starting keyframes. The difference between absolute and relative starting keyframes is subtle but important. 
When a timeline has absolute starting keyframes, elements animated by that timeline will have their animated proper-
ties set to the values defined by the starting keyframes when those keyframes are triggered, and will then animate to 
the values defined by their ending keyframes. When a timeline has relative starting keyframes, elements animated by 
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that timeline will use their current values when the starting keyframes are triggered, and will then animate to the val-
ues set by their ending keyframes.!

This difference makes timelines with absolute starting keyframes useful for effects such as looping. When loop-
ing, it’s often desirable to have elements jump back to their starting properties; when building complex animations, it 
can be handy to use timelines with relative starting keyframes that animate elements from their current state, whatev-
er it may be, rather than forcing elements to a pre-defined initial state.!

Making a Timeline Relative or Absolute!
Toggle whether a timeline’s first keyframes should be relative by opening the Scene inspector and selecting the 

Relative checkbox in that timeline’s entry in the Animation Timelines table. Absolute keyframes are always drawn with 
a diamond, while relative keyframes are drawn as a circle.!

�

� !

Animation Timelines in the Scene Inspector
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Because relative keyframes take the element’s property’s current value when the timeline is started, there are 
some situations where Tumult Hype cannot definitively indicate whether an animation will happen. In the example 
below, the Move Soccerball timeline is active and uses relative keyframes. Because the Origin (Left) animation has 
different starting and ending values, Tumult Hype knows that animation will always take place. The Origin (Top) ani-
mation, however, has the same starting and ending values. As such, that animation will only happen if the element is 
currently at a different Origin (Top) value when the timeline is started. Because of this uncertainty, Tumult Hype draws 
the Origin (Top) animation bar slightly transparent, indicating that the Origin (Top) animation between the starting rela-
tive keyframe and ending absolute keyframe may not have any effect on the scene.!

� !

Relative Keyframes Example!
Because relative keyframes take into account the position of elements on other timelines, they can be taken ad-

vantage of to create smooth animations that animate elements across timelines. Download a sample document 
demonstrating relative timelines. 

Potential Animation With Relative Keyframes
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Actions!
Scenes, timelines, and animations are the foundation of all Tumult Hype documents. Actions link together this 

foundation and make documents interactive. Actions are triggered five different ways:!

1. In response to mouse or touch events.!
2. In response to scene events.!
3. In response to keyboard events.!
4. At specific times on a timeline.!
5. Via JavaScript.!

This chapter will discuss the first three triggers, as well as the types of actions and action chaining. Tumult 
Hype’s JavaScript API is discussed in the JavaScript chapter.!

Mouse and Touch Actions!
Any element can respond to both mouse and touch actions. Set an action on an element by selecting the ele-

ment, opening the Actions inspector, and then clicking the Plus button next to any action handler. If Use Touch Events 
is enabled in the Document inspector, events are mapped to the tap action in parenthesis. The following six actions 
can be detected:!

• Mouse Click (Tap) — A complete click (a mouse down followed by mouse up) has been completed.!
• Mouse Down (Touch Start) — Once the pointing device has been depressed on the element.!
• Mouse Up (Touch End) — The mouse button has been released after being pressed.!
• Mouse Over — The cursor has entered the bounds of the element.!
• Mouse Out — The cursor is no longer within the bounds of the element.!
• On Drag — A drag has begun on the indicated element.!

• Control Timeline — Horizontally or vertically dragging across the selected element controls playback 
of the selected timeline. The axis dropdown defines whether a horizontal or vertical drag controls the 
timeline. The direction dropdown defines whether the indicated timeline plays forwards or backwards. 
Select ‘Continue after drag’ to maintain the momentum of the timeline's playback after releasing.!

• Control Element Position — Controls the position of the element when dragged.!
• For deeper control over dragged elements, see the JavaScript Drag API section of the documenta-

tion.!
Most mouse actions translate logically to touch actions. For example, tapping an element invokes that element’s 

touchstart action. For more information about touch support, please see the Touch & Mobile chapter. By default, a 
tap on a mobile device will be triggered at the start of a touchstart event. To change this behavior, disable Use 
touch Events in the Document inspector.!

To correctly trigger mouse actions, elements must not have other elements above them or overlapping with them.!
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Set an action on a button by selecting the button, activating the Mouse Action inspector, and then clicking the 
Plus button next to the On Mouse Click action header:!

� !

Scene Actions!
Scene actions trigger in response to scene events and are useful for scene-specific interactivity. The following 

scene actions can be triggered:!

• On Scene Load — Triggered when entering the scene.!
• On Scene Unload — Triggered when leaving the scene.!
• On Any Timeline Complete — Triggered when any timeline in the current scene has finished playing.!
• On Key Press — Triggered when a character key has been pressed and released.!
• On Key Down — Triggered when pressing a keyboard key.!
• On Key Up — Triggered when a keyboard key has been released.!
• On Swipe Left — Triggered when the scene is swiped from right to left.!
• On Swipe Right — Triggered when the scene is swiped from left to right.!
• On Swipe Up — Triggered when the scene is swiped from bottom to top.!
• On Swipe Down — Triggered when the scene is swiped from top to bottom.!
• On Drag — Triggered when the scene area is dragged.!

• Control Timeline — Horizontally or vertically dragging across the scene controls playback of the 
selected timeline.!

• For deeper control over dragged elements, see the JavaScript Drag API section of the documenta-
tion.!

Timeline Actions!
Timeline actions fire at a certain point in a timeline. Add a new timeline action at the playhead’s current position 

by clicking the Plus button in the Timeline Actions gutter, or by double clicking anywhere on the Timeline Actions’ 
timeline. Existing Timeline Actions can be edited by double clicking on their associated keyframe.!

A Mouse Action Set on a Button
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To run a Timeline action at the end of a timeline, you may also use the On Any Timeline Complete action in the 
Scene inspector. This action is triggered every time any timeline in the current scene completes playing. For further 
control over actions beyond Timeline Actions, please see the JavaScript API documentation.!

� !

Edit an existing Timeline Action by double clicking on its associated keyframe to open the Timeline Action pop-up 
window:!

� !

Example Timeline Actions!
Here are a few examples of what Timeline Actions can be used for:!

• Looping an animation — To loop an animation, you can set a timeline action to either Start Timeline or 
Go to Time in Timeline for the same timeline.!

• Jumping to a scene or running an alternate timeline — Create interactivity that navigates to specific 
points in scenes and timelines. You would create multiple animations on one timeline, and use the Pause 
and Continue actions to move between them.!

Download a sample document demonstrating timeline actions. 

Timeline Actions

Timeline Actions Pop-up Window
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!
Types of Actions!

The types of actions possible for scene, mouse, or time-based events are the same. The action menu throughout 
Tumult Hype provides quick access to eight different actions and one command.!

� !

• Jump to Scene — Change to the previous, next, or arbitrarily 
specified scene, using one of the following seven scene transi-
tions:!

• Instant!
• Crossfade!
• Swap!
• Push (Left to Right)!
• Push (Right to Left)!
• Push (Bottom to Top)!
• Push (Top to Bottom)!

The Duration slider offers control over how long the chosen transition should animate.!!
Note: The Swap transition is only shown in WebKit-based browsers, Firefox, and Internet Explorer 10.!

!
Download a sample Hype document demonstrating scene transitions.!

• Run JavaScript — Invokes a JavaScript function. See the JavaScript chapter to learn more about what’s 
possible with JavaScript in Tumult Hype.!

Available Actions
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• Go to URL — Loads a URL.!
• Compose Email — Composes an email, with optional subject line and body fields.!
• Play Sound — Starts the selected sound.!
• Stop Sound — Stops the selected sound.!
• Start Timeline — Start playback of any timeline in the current scene.!
• Pause Timeline — Pause playback of any timeline in the current scene.!
• Continue Timeline — Resume playback of any timeline in the current scene.!
• Go to Time in Timeline — Jump to a specified time in any timeline in the current scene.!
• Remove — Removes the associated action.!

Chaining Actions!
More than one action can be triggered in response to an event. For example, a button click could sequentially 

perform these two actions:!

1. Go to Time in Timeline…!
2. Continue Timeline…!

Clicking the Plus button in any action handler’s section appends a new action to the end of the action chain.!

� !!
Adding Actions
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Flexible Layout!
Hype offers a powerful layout system for resizing and scaling documents, allowing Hype animations to respond 

as the browser’s window or device’s viewport changes size.!

Document Scaling!
By default, Tumult Hype animations have a fixed width and height, and do not respond to window or viewport 

size changes. To make your animation responsive to size changes, you must first select the Width and Height Scale 
checkboxes in Hype’s Document inspector. Enabling these options allows your document to respond to width or 
height size changes as desired.!

!
The Width and Height Scale options are complimented by percentage fields which define how much of the con-

taining window or div the Hype document should fill. The default value is 100%, which means the Hype document will 
expand or contract to fill the width or height of its container. Reducing this number restricts how the document will 
expand. For example, setting the value to 50% means the Hype document will only expand to fill half of the width or 
height of its container.  !

!
Element Pinning and Sizing!

Enabling document scaling is only the first step for creating a completely responsive document. After deciding 
how your document should scale, you then need to define how elements in the document should adapt to size 
changes.!
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This is done by “pinning” elements to edges of the scene, allowing the elements to resize horizontally or vertical-
ly, and, for proportionally sized elements like images, controlling how they should scale. Hype’s Element inspector 
offers a Flexible Layout section which contains all of the controls for managing how elements should adapt to docu-
ment size changes.!

� !

Pinning!
Pinning an element to an edge instructs that element to move as the edge itself moves. When pinned to non-

opposing edges, such as the bottom and right edge, the distance from the element to those edges remains fixed. In 
other words, an element that is placed 100 pixels away from the right edge and is also pinned to the right edge will 
change its location as the document resizes so it’s always 100 pixels away from the right edge.!

When an element is pinned to opposing edges, the element’s location changes so the proportion of the distance 
from the element’s center to the opposing edges is always preserved. The best example for this case is element cen-
tering: an element that is centered between the right and left edges and is also pinned to those edges will always be 
centered regardless of how the document’s size changes. !

A more complex example is an element in a 1000px wide document whose center is 200px from the left edge 
and 800px from the right edge. When this element is pinned to both edges and the document has width scaling en-
abled, the element’s center will always be positioned so that 20% of the document’s width is between itself and the 
document’s left edge while 80% of the distance is between itself and the right edge.!

Sizing!
Element resizing is controlled by the two sizing arrows presented in the Element inspector’s Flexible Layouts 

section. By default, both sizing arrows are disabled which means that neither the element’s width nor height will 
change as the document’s size changes. Enabling either one or both of the arrows allows the element to change its 
size either horizontally or vertically. Like pinning, an element’s size changes proportionally to the document’s size. 
Thus, an element whose height is 20% of the document’s height will resize to ensure its height is always 20% of the 
document’s height.!

Scaling Behavior!
The scaling behavior control allows you to change how elements should be resized. This control is only enabled 

when an element is allowed to resize both its width and height. When an element is allowed to resize in both dimen-
sions, the default scaling behavior is to stretch the element. This is ideal in most situations, but there are times – such 
as when an image is being resized – where an element should not be arbitrarily stretched and instead its proportions 
should be preserved.!

To handle those situations, Hype offers two additional scaling behaviors which preserve the element’s aspect 
ratio: Shrink to Fit and Expand to Fill. When Shrink to Fit is chosen, Hype ensures that the element will never expand 
outside of its bounding region. Conversely, when Expand to Fill is chosen, Hype will make sure the element always 
fills its bounding region, even if that means it may spill outside.!

Element Pinning, Sizing, and Scaling Settings
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As an analogy, consider what happens when watching wide-screen content on a TV: viewing that content letter-
boxed  is similar to Shrink to Fit as all of the content is always visible on the TV. Likewise, viewing the same content 
fullscreen is similar to Expand to Fill, as the video expands to fill the TV even though some content falls off the 
screen.!

� !

Animations!
Both standard animations and motion paths take into account the element’s sizing and pinning settings, and 

adapt to the element’s position and size changes as needed. 
Viewport Settings!

Documents with a scaling turned on for the height dimension will not display vertical scrollbars. Likewise, docu-
ments with a scale percentage set on their width dimension will not display horizontal scrollbars. If small screen sizes 
conceal parts of your document outside of the viewport, uncheck the 'height' scale checkbox. To specifically address 
issues with hidden content on mobile devices, set the viewport width property of your document to 'device height'. For 
more information on the viewport property, read the Touch & Mobile chapter. 

Scaling Behavior Illustrated
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Touch & Mobile!
Tumult Hype offers several options for producing touch-friendly interactivity for:!

• iBooks Author Widgets!
• Animations on the web!
• Interactive elements within mobile applications!
• Animations accessible from a touch screen!

This chapter explores initial configuration options for your document, touch actions available at the scene and 
element level, and offers tips for optimizing for touch screens.!

Document Options!
The Document inspector contains basic configuration options for your Hype document.!

• Document Size – When selecting a docu-
ment size, choose from many different mo-
bile device sizes in the document size drop 
down.!

• Create offline application cache – When 
selected, Tumult Hype generates a cache 
manifest file for resources used in your 
project. With this option selected, your doc-
ument, when loaded as a web app, will 
download and locally save everything need-
ed to ensure the document works even 
when the device is offline. Note: Your doc-
ument will need to be loaded once as a web app to prime the cache. Also, Google fonts require an Inter-
net connection as they cannot be cached on the device.!

• Viewport – Choosing Document Width sets the document’s viewport to match your document’s width. 
Device Width and Device Height define the exported document’s viewport to match the viewing screen’s 
width or height. Choosing Don’t Set excludes any viewport tag from your document’s exported content.!

• Initial Scale 1.0 – Selecting this option adds the “initial-scale=1.0” property to the exported page’s view-
port.!

• Allow user scaling – When selected, users can pinch and zoom to zoom in to and out of your document.!
• Use touch events – When selected, actions set in the Actions inspector default to tap events when pos-

sible. For example, a Mouse Click will be fired after a Tap without any delay.!
• Show tap highlight – When selected, the default tap highlight color appears when tapping elements. Tap 

highlight does not appear when 'Use Touch Events' is selected.!
• Home screen web app – This option allows visitors to add your web app to their iOS device’s home 

screen.!
• Status bar – If “Home screen web app” is enabled, allows you to choose the desired appearance for your 

web app’s status bar.!
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Scene Touch Actions!
Scene level touch actions — such as swiping and dragging on the scene — can trigger one or more actions. 

Swipe actions are a great way to introduce mobile device support in your document’s navigation. For example, the 
following action creates a natural swiping motion between scenes.!

� !

In addition to swiping up, down, left and right, you may also trigger actions from Drag events. Drag events at the 
scene level can control the playback of a timeline when dragging horizontally or vertically, or it may optionally trigger 
JavaScript. Our JavaScript API offers more options for the dragging API.!

Element Touch Actions!
By default, Tumult Hype optimizes events that occur on touch events. For example, a tap on a link in Mobile Sa-

fari fires only after a 300ms delay, regardless of the speed of the tap. With Use Touch Events enabled in the docu-
ment inspector, tap actions fire after the finger has left the surface of the screen. The tables below provide a bit more 
information on these events and how they behave with or without Use Touch Events.!

“Use Touch Events” Enabled!

Scrolling & Touch Events: The mouse click event fires after the element has been tapped. It triggers on Touch 
End but will cancel if a scroll begins before that occurs. If touch events are enabled, a scrolling movement that begins 
on an element with a Mouse Down event, the action will fire.!

Action Name Mouse Event Touch Event

On Mouse Click Mouse Click Tap on Element

On Mouse Down Mouse Down touchstart

On Mouse Up Mouse Up touchend

On Mouse Over Hover n/a

On Mouse Out End Hover n/a

On Drag Click and Drag Tap and Drag
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“Use Touch Events” Disabled!

When Use Touch Events is disabled, if you begin scrolling on an element with a Mouse Down event, a Mouse 
Down event will not fire.!

For more information about touch events and emulated mouse events, please see Safari Web Content Guide: 
Handling Events.!

Testing!
Touch actions work on mobile and desktop browsers, but to really test how a touchable interface behaves, test 

on the mobile browser and device you’d like to support and host your document from a staging server.!

Hype Reflect is a free companion iOS app that streamlines previewing Hype documents on iOS devices. When 
Reflect is open on an iOS device, Hype Reflect appears as a preview option alongside Safari, Chrome, and other 
browsers. Learn more about Hype Reflect and read the Previewing chapter.!

Use Mobile Safari’s developer tools to profile and test actions, events, and resources from your Mac. Note that 
Hype Reflect also has a console for reading console.log(); events.!

When designing for touch devices, make sure your tappable elements are the right size for fingers. Read Getting 
Started with iOS Web Apps for tips on designing for touch screens.!

Tips!
• Exporting to different platforms and content management systems: Please see our Exporting FAQ.!
• Decrease loading times: To improve the performance of your document, optimize your site by reducing 

preloading and by optimizing images.!
• Apple Touch Images: When a web page is added to the home screen of an iOS device, images may be 

used to define icons and startup images for the various device sizes. You may define images to use for 
iPhone and iPad users’ home screen icons and startup/loading images.  
First, add your images to your resource library, and reference them using the ${resourcesFolderName} 
variable. Use the code snippet below in the <head>…<head> area to load these images. Edit the contents 
of the <head>…<head> of your exported .html file by selecting Edit HTML Head in the Document Inspec-
tor.!

Action Name Mouse Event Touch Event

On Mouse Click Mouse Click Emulated Mouse Event +300ms delay

On Mouse Down Mouse Down Emulated Mouse Event +300ms delay

On Mouse Up Mouse Up Emulated Mouse Event +300ms delay

On Mouse Over Hover n/a

On Mouse Out End Hover n/a

On Drag Click and Drag Tap and Drag
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<!-- Springboard Icons --> 
<!-- non-retina iPhone pre iOS 7 --> 
<link rel="apple-touch-icon" href="${resourcesFolderName}/icon57.png" sizes="57x57"> 
<!-- non-retina iPad pre iOS 7 --> 
<link rel="apple-touch-icon" href="${resourcesFolderName}/icon72.png" sizes="72x72"> 
<!-- non-retina iPad iOS 7 --> 
<link rel="apple-touch-icon" href="${resourcesFolderName}/icon76.png" sizes="76x76"> 
<!-- retina iPhone pre iOS 7 --> 
<link rel="apple-touch-icon" href="${resourcesFolderName}/icon114.png" 
sizes="114x114"> 
<!-- retina iPhone iOS 7 --> 
<link rel="apple-touch-icon" href="${resourcesFolderName}/icon120.png" 
sizes="120x120"> 
<!-- retina iPad pre iOS 7 --> 
<link rel="apple-touch-icon" href="${resourcesFolderName}/icon144.png" 
sizes="144x144"> 
<!-- retina iPad iOS 7 --> 
<link rel="apple-touch-icon" href="${resourcesFolderName}/icon152.png" 
sizes="152x152"> 
<!-- Startup Images --> 
<!-- iPhone --> 
<link href="${resourcesFolderName}/apple-touch-startup-image-320x460.png" 
       media="(device-width: 320px) and (device-height: 480px) 
          and (-webkit-device-pixel-ratio: 1)" 
       rel="apple-touch-startup-image"> !
<!-- iPhone (Retina) --> 
<link href="${resourcesFolderName}/apple-touch-startup-image-640x920.png" 
       media="(device-width: 320px) and (device-height: 480px) 
          and (-webkit-device-pixel-ratio: 2)" 
       rel="apple-touch-startup-image"> 
<!-- iPhone 5 --> 
<link href="${resourcesFolderName}/apple-touch-startup-image-640x1096.png" 
       media="(device-width: 320px) and (device-height: 568px) 
          and (-webkit-device-pixel-ratio: 2)" 
       rel="apple-touch-startup-image"> 
<!-- iPad --> 
<link href="${resourcesFolderName}/apple-touch-startup-image-768x1004.png" 
       media="(device-width: 768px) and (device-height: 1024px) 
          and (orientation: portrait) 
          and (-webkit-device-pixel-ratio: 1)" 
       rel="apple-touch-startup-image"> 
<link href="${resourcesFolderName}/apple-touch-startup-image-748x1024.png" 
       media="(device-width: 768px) and (device-height: 1024px) 
          and (orientation: landscape) 
          and (-webkit-device-pixel-ratio: 1)" 
       rel="apple-touch-startup-image"> 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Hype Reflect!
Tumult Hype’s mobile gestures and web app support provide you with amazing tools to create mobile content, 

and Hype Reflect for iOS allows you to quickly preview your Tumult Hype document on any iOS device. Watch a 
video about Hype Reflect to learn more.!

Connecting to Hype Reflect!
Preview your Tumult Hype document in Hype Reflect by following these steps:!

1. Download Hype Reflect from the iOS App Store.!
2. Make sure that your Mac and your iOS devices are connected to the same Wi-Fi network.!
3. In Tumult Hype on your Mac, click the Preview menu in the toolbar and choose your iOS device.!

Your current Hype document should appear on your iOS device, in Hype Reflect.!

If you close Tumult Hype on your Mac or leave your WiFi network, the preview will close in Hype Reflect.!

� !

!

Preview drop-down in Tumult Hype: 
Available devices highlighted blue

Tumult Hype 2.5 Documentation! �                                                                                                                                   48

http://localhost/hype/reflect/


Preview Mode!
When you initially preview your document, your document is in Preview mode. In this mode, your document be-

haves almost exactly as if it were viewed in Mobile Safari itself.!

Switch between different scenes within Hype Reflect by tapping the Scenes icon in the upper left hand corner 
and choosing your desired scene. Reload the document by tapping the reload button; this is a quick way to get most 
recent changes made in Tumult Hype.!

!
Mirror Mode!

While in Mirror Mode, Hype Reflect instantly mirrors every single change made in Tumult Hype. This makes Mir-
ror Mode a fantastic tool for designing iOS content. Enable Mirror Mode by tapping the �  icon.!
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More Options!
While using Hype Reflect on an iPhone or iPod, you may enable the following options by tapping the �  icon 

Hype Reflect’s toolbar:!

• Open in Safari – Opens the current document within Mobile Safari.!
• Console – Displays any JavaScript console logs.!
• Fullscreen – Simulates a full screen web app. To exit fullscreen, click the icon in the lower left hand cor-

ner.!
Note: These options appear in the toolbar for iPads. To preview in a local browser, please see the Previewing & 

Exporting chapter.!

FAQ!
I'm unable to connect to Hype Reflect. What do I do?!

1. Make sure that your iOS device and your computer are connected to the same WIFI network.!

2. Restart your iOS device. & turn WIFI on your Mac off and on.!

3. Open System Preferences on your Mac and open the 'Security and Privacy' or 'Security' area. In the 
'Firewall' section, click 'More Options' and make sure that 'Block all incoming connections' is not checked. 
(View Screenshot).!

4. Make sure that firewall applications such as Little Snitch do not block connections requested by Tumult 
Hype. To edit blocked applications, open Little Snitch's preferences.!

5. Make sure that devices on your local area network can connect to other devices on your network. Your 
router should not be blocking connections between local devices; you may need to contact your network 
administrator to resolve this issue.Note: These options appear in the toolbar for iPads. To preview in a local 
browser, please see the Previewing & Exporting chapter.!

If the suggestions above do not work, you can connect to Hype Reflect by creating an ad hoc network between 
your Mac and your iOS device based on these instructions. Please note this may disrupt your connection to the Inter-
net. Please get in touch if you continue to have issues connecting.!

!
!
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Previewing & Exporting!
This chapter covers previewing your Tumult Hype document on local browsers and and exporting your document 

to the web.!

Preview in a Browser!
By default, your system’s default browser is presented as the icon for the Preview toolbar button, and clicking the 

button opens your current document in the default browser. Clicking the drop down menu next to the Preview button 
displays a list of all common installed browsers, and choosing from any of those browsers will both preview your doc-
ument in that browser and make that browser the new default for the Preview toolbar button. To preview just the cur-
rent scene being edited, choose File > Preview in Browser > Preview Current Scene in Browser, or Option-click the 
Preview toolbar button.!

To preview directly on an iOS device, please see the Hype Reflect chapter.!

By default, only common browsers will be shown in the Preview menus. You prevent this filtering by disabling the 
“Only show recommended browsers in preview menu” option in Hype’s preferences.!

� !

Exporting!
Tumult Hype exports documents to HTML5. Exporting is a one-way process; Tumult Hype will not read back any 

modifications made to the exported code.!

Generated HTML!
To generate HTML, choose File > Export as HTML5 > Folder…. By default, Tumult Hype will create a folder con-

taining two items:!

An .html document!
Open this in your browser to see your document in action. If you need to put your content into a different docu-

ment, see Embedding in Other HTML Documents.!

A resources folder!
This folder contains all image, video, and file resources stored in the document, along with these files:!

• HYPE.js — The main runtime for all Tumult Hype documents.!

Available Preview Options
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• documentName_hype_generated_script.js — The document-specific data which defines all scenes, 
timelines, elements, and animations for the document.!

• PIE.htc — An HTML component for Internet Explorer, used in Internet Explorer 6 through 8 to improve 
browser compatibility. See css3pie.com for more info.!

• blank.gif — A special image which improves transparent GIF rendering in Internet Explorer 6 through 8.!
• cache.manifest — Enumerates the document’s resources for offline caching. Only present if the Create 

Offline Application Cache option is enabled in the Document inspector.!
• HYPE.ie.js — JavaScript used by IE6–8 for compatibility.!
• ####-restorable.plist — Document restoration file which can be used to recover the original Hype docu-

ment from the exported content. Learn more about this file in the Document Recovery section later in this 
chapter.!

When exporting, the file structure of a document typically looks like this:!

� !

Export Options!
At export time, there are several different options you can toggle:!

� !

Also save .html file!
If this is enabled, it will output the HTML file mentioned above. Disabling this option is useful if you’ve made mod-

ifications to the HTML file and do not want it to be overwritten, or if you have a different HTML file you are using in-
stead.!

Exported Folder Contents

Export Options
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Include text contents for search engines!
When enabled, Hype will include all of the text found in your document’s elements in special hidden text ele-

ments appended to the HTML file. Those text elements help your document be indexed by Google and other search 
engines.!

Create enclosing folder!
When this is enabled, Tumult Hype will create a top-level folder which will hold the .html file and the *.hypere-

sources folder. Disable this option if you want Tumult Hype to only write these in the specified folder.!

Show “Built with Tumult Hype”!
Tumult Hype documents will show a small “Built with Hype” watermark in the lower left corner. If you disable this, 

the watermark will not be shown.!

Image Optimization!
To help minimize document size, improve compatibility with all browsers, and improve rendering on high resolu-

tion “retina” displays, Tumult Hype will by default:!

• Convert non-web safe images – any image that is not a PNG, JPEG, GIF, or SVG – to a PNG or JPEG. If 
the source image has any transparency, Tumult Hype will convert it to a PNG to preserve that trans-
parency. Otherwise the non-web safe image is converted to a JPEG to minimize size.!

• Resize images so they’re only as large as is needed for the document. For example, if you use an 18 
megapixel 5184px ⨉ 3456px image as the background for a 600px ⨉ 400px scene, Tumult Hype will resize 
the image on export and reduce the final download size by megabytes.!

• Create high resolution “@2x” images that will be downloaded by devices with “retina” displays, if the 
source image is large enough. Automatically generated high resolution images are only downloaded by 
desktop computers with retina displays, so they don’t affect download times for anyone else. !

The following two scenarios illustrate Tumult Hype’s default image export behavior:!

• Given a 200px ⨉ 200px JPEG displayed as a 50px ⨉ 50px image, Tumult Hype generates a 50px ⨉ 50px 
image during export that is downloaded and displayed to most users. A high resolution 100px ⨉ 100px 
image is also generated, and is provided to users with “retina” displays.!

• Given a PDF displayed as a 100px ⨉ 100px image, Tumult Hype will convert the first page to a 100px ⨉ 
100px PNG for standard displays as well as a 200px ⨉ 200px PNG for high resolution displays.!

• Given a 100px × 100px image JPG named file@2x.jpg and a 50px × 50px image named file.jpg, Tumult 
Hype will group the two images. The @2x image will be loaded on ‘retina’ screens, and the non-retina im-
age will be loaded on non-retina screens.!
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Tumult Hype’s automatic image optimization can be disabled by choosing an image in the Resource Library and 
deselecting the “Automatically optimize when exporting” option:!

� !

Hosting Your Document on the Web!
The quickest way to host your Tumult Hype document on the web is to upload your exported .html file and 

the .hyperesources folder to your hosting provider. You can then visit the URL of your .html file to load your document.!

For a video walkthrough on getting your Tumult Hype document on the web, please see this video tutorial.!

Embedding in Other HTML Documents!
A good starting point for embedding is to set the export option to save the HTML file. The file is relatively bare-

bones and contains three critical lines which will actually kick off the document:!

<!-- copy these lines to your document: --> 
 
<div id="documentName_hype_container"   
     style="position:relative;overflow:hidden;width:600px;height:400px;"> 
    <script type="text/javascript" src="documentName.hyperesources/
documentName_hype_generated_script.js?56206"></script> 
</div> 
 
<!-- end copy --> 

These lines can be copied and pasted into other documents; two div tags and one script tag are all you need. 
They reference the .hyperesources folder, which also needs to be placed at the same level as the HTML file. To open 
HTML files, you’ll need a HTML editor. Here are a few we recommend. Note: this example uses “documentName” as 
the exported document’s name, so the lines in other exported documents will be different. Please be certain to re-
place any instances of “documentName” with the proper document name if you’re copying directly from this example.!
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Dropbox!
Dropbox allows you to sync your files online and across your computers automatically. To learn more or sign up 

for a Dropbox account, visit dropbox.com.!

All documents published to Dropbox are public, Tumult Hype so you can easily share your work with others. 
Dropbox must first be setup in Tumult Hype’s application preferences. To export to Dropbox, choose File > Export as 
HTML5 > Dropbox. After uploading, Tumult Hype will let you view the page from Dropbox’s servers or copy the URL 
to share with others.!

iBooks!
To export your Tumult Hype animation as an iBooks and Dashboard-compatible widget file, choose File > Export 

> Dashboard/iBooks Author Widget. Tumult Hype offers four pre-defined iBooks document sizes to choose from in the 
Document inspector, which are useful for creating animations specifically tailored to iBooks.!

Insert Dashboard/iBooks Author Widgets into iBooks Author documents by choosing Insert > Widget > HTML 
from within iBooks Author, or dragging and dropping the exported widget into an open iBooks Author document.!

If you have any additional questions not covered here, please visit the iBooks Author HTML widget support fo-
rum. If you're interested in how a iBooks widget is built, please see our blog post.!

Video and Animated GIF!
Create a video or animated GIF of your Tumult Hype document by choosing File > Export as Movie > Video or 

File > Export as Movie > Animated GIF. The export dialog which appears allows you to change the duration, frame 
rate, and dimensions of the video. Clicking Save creates a MP4 video of your document.!

� !

The duration defaults to time it will take for all animations to finish or five minutes if there is a loop. Timeline and 
scene actions can be used to extend the recordable portion of your document. For example, set an On Any Timeline 
Complete action at the end of the Main Timeline to transition to the next scene. If the animation on your first scene 
was 5 seconds, and the animation on your second scene was 10 seconds, the default video duration will be 15 sec-
onds. !

Export as Movie Dialog
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Note that any audio embedded in your document is not included in either video or animated GIF exports. Also 
note that video exporting is only supported on OS X 10.7 “Lion” and later.!

Exporting to Other CMSs and Platforms!
Since Tumult Hype document are built in HTML, Javascript, and CSS, they can be run displayed on a large 

number of devices. We have covered step-by-step instructions for many platforms in this Exporting FAQ.!

Document Recovery!
By default, Tumult Hype exports a recovery file from which the original Hype document can be recreated. This 

file is never downloaded by users viewing your document online, so it does not impact download times. Also, the file 
name is randomized per-document, so that it’s not easy for someone else to download and recreate your source 
Hype document.!

If you have lost your source Hype document, you can recover it by following these steps:!

1. Download the exported “<documentname>.hyperesources" folder.!
2. Choose Help > Restore Document from Export… and select the “####-restorable.plist” file in the down-

loaded .hyperesources folder.!
3. Choose where to save your recovered document.!

While the recovery process should re-create your source Hype document in the exact same state as it was dur-
ing export, it is no replacement for a true back up system. Please use a back up system like Time Machine to protect 
your valuable data.!

If for some reason you don’t want restorable document data included in your exports, disable this behavior by 
deselecting the “Create restorable document file when exporting” option in Hype’s General preferences.  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Resources!
Resources are the images, videos, JavaScript functions, and other files that have been added to a Tumult Hype 

document. Unlike elements, which are unique to each scene, resources are shared across the entire Tumult Hype 
document. When playing back in a browser, Tumult Hype documents are careful to only download one copy of each 
resource and share that copy across all scenes.!

Resource Library!
Tumult Hype’s Resource Library offers control over a document’s resources. Open the Resource library by 

choosing View > Resource Library or clicking the Resource toolbar button. The Resource Library offers controls for 
filtering and searching resources, and also provides numerous controls for managing resources.!

Adding Resources!
Clicking the Resource Library’s Plus button provides a menu from which new files can be added to or new Java-

Script functions can be created in the front-most document. Any file can be added to the Resource Library and will be 
included in the .hyperesources folder upon export. Images and videos in the Resource Library can be added to a 
scene by dragging them from the Resource Library and dropping them on the scene.!

Resource Groups!
Images, videos, and audio resources all create resource groups, where one resource references multiple files. 

Resource groups are used to collect different file variants which may be used by the resource in different contexts. 
Audio and video resource groups have place holders for the different file encodings which are required by browsers, 
and image resource groups offer place holders for standard resolution images and “@2x” images. It’s important to 
note that adding additional files to a resource group will not adversely affect the document’s download time: browsers 
will only ever download the single file they need from a resource group, ignoring the other files in the group.!
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To add additional audio or video sources to a resource group, select the grayed out source in the Resource Li-
brary, click the Add Source… button, and then choose the appropriate audio, video, or image file. For example, a 
“video/webm” resource may be added to the Video2 resource group shown below. Additional sources can also be 
dragged onto the Resource Library, and Hype will attempt to add those resources to the correct resource group.!

� !

Updating Resources!
Every time a file-based resource is added to a Tumult Hype document, Tumult Hype stores a copy of the file in 

the document and also keeps a link to the original file. Whenever the original file is modified, Tumult Hype automati-
cally prompts to see if the copy stored in the current Tumult Hype document should be updated to match the original 
file outside of Tumult Hype. Clicking the Refresh button manually updates the file. Sometimes the connection be-
tween the original files and Tumult Hype’s copy is broken; this often happens when the Tumult Hype document is 
moved to a different computer, or if the original source file is saved under a different name. Should this happen, Tu-
mult Hype displays a Choose dialog so you can find the original file, restore the connection, and update the current 
Tumult Hype document’s copy of the file.!

Replacing Resources!
To replace any file-based resource with a different file, click the Replace… button. The Choose dialog which ap-

pears lets you pick the replacement file. This is a very powerful tool for quickly replacing all copies of an image or 
video across all scenes in a document.!

Removing Resources!
Clicking the Minus button removes any resources that aren’t actively used by elements in the document’s 

scenes. Any images and videos that are currently used in the document cannot be deleted until all elements using 
those resources have first been deleted.!

By default, Tumult Hype automatically deletes image and video resources when all elements using those re-
sources have themselves been deleted. To prevent this behavior so that images and videos persist in the document 
even after all elements using those resources have been deleted, deselect the “Remove when no longer referenced” 
checkbox.!
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Controlling Preloading!
By default, Tumult Hype documents preload all image resources before beginning any animation. This is done to 

ensure viewers always see the document as it appears in Tumult Hype, with no missing images. This behavior can be 
disabled on a per-image basis by first choosing an image from the resource list and then deselecting the Preload 
checkbox. Videos are not preloaded so there is no control for this behavior.!

Image Optimization!
To help minimize document size, improve compatibility with all browsers, and improve rendering on high resolu-

tion “retina” displays, Tumult Hype will by default:!

• Convert non-web safe images – any image that is not a PNG, JPEG, GIF, or SVG – to a PNG or JPEG. If 
the source image has any transparency, Tumult Hype will convert it to a PNG to preserve that trans-
parency. Otherwise the non-web safe image is converted to a JPEG to minimize size.!

• Resize images so they’re only as large as is needed for the document. For example, if you use an 18 
megapixel 5184px ⨉ 3456px image as the background for a 600px ⨉ 400px scene, Tumult Hype will resize 
the image on export and reduce the final download size by megabytes.!

• Create high resolution “@2x” images that will be downloaded by devices with “retina” displays, if the 
source image is large enough. Automatically generated high resolution images are only downloaded by 
desktop computers with retina displays, so they don’t affect download times for anyone else. !

The following two scenarios illustrate Tumult Hype’s default image export behavior:!

• Given a 200px ⨉ 200px JPEG displayed as a 50px ⨉ 50px image, Tumult Hype generates a 50px ⨉ 50px 
image during export that is downloaded and displayed to most users. A high resolution 100px ⨉ 100px 
image is also generated, and is provided to users with “retina” displays.!

• Given a PDF displayed as a 100px ⨉ 100px image, Tumult Hype will convert the first page to a 100px ⨉ 
100px PNG for standard displays as well as a 200px ⨉ 200px PNG for high resolution displays.!

Disable Tumult Hype’s automatic image optimization by choosing an image in the Resource Library and dese-
lecting the “Automatically optimize when exporting” option:!

� !
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Including CSS and JavaScript in Document <head>!
When CSS or JavaScript files are tracked by a document’s Resource Library, Tumult Hype can automatically 

include references to those files in the document’s header when exporting. This behavior is the default; to disable, 
choose the CSS or JavaScript file which should not be included in the document’s header and deselect the “Include 
in document <head>” checkbox.!

� !

Referencing Resources in Code!
Because resources stored in Tumult Hype documents are exported into an animation’s resources, it’s possible to 

reliably refer to them in the document’s <head> or in JavaScript functions created within Tumult Hype.!

In a Document’s <head> or an Element’s Inner HTML!
Tumult Hype provides a special HTML variable, ${resourcesFolderName}, which always properly references the 

resources folder Tumult Hype creates when exporting a document. Use this this variable anywhere a URL path is 
expected. For example, after adding the file jquery-1.8.2.min.js to your document using the Resource Library, refer-
ence that file in your document’s <head> via!

<script src="${resourcesFolderName}/jquery-1.8.2.min.js"> !
Similarly, after adding the image globe.png to your document, you could refer to the image in an element’s inner 

HTML with!

<img src="${resourcesFolderName}/globe.png"> !
When exporting the document, Tumult Hype will always replace the ${resourcesFolderName} variable with the 

correct path.!

In JavaScript Functions!
Tumult Hype offers a JavaScript API for returning the string value of the document’s resources folder URL: 

hypeDocument.resourcesFolderURL(). Use this in any JavaScript functions to reliably access the document’s associ-
ated resources folder. For example, if the document had an image named logo.png, the image’ path could be con-
structed in a JavaScript function via!

var logoImagePath = hypeDocument.resourcesFolderURL() + "/logo.png"; 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JavaScript!
Using JavaScript!

Creating a new JavaScript!
JavaScript functions within Tumult Hype are generally run in response to user events. In any action panel, such 

as the panels found in the Mouse Actions inspector, create a 
JavaScript function by following these steps:!

1. Click the Plus button in the action’s header to 
add a new action.!

2. Click the Action menu and choose Run Java-
Script… .!

3. Click the Function menu and choose New 
Function… .!

This will open a new JavaScript Editor tab where cus-
tom JavaScript functions can be written. A sample JavaScript 
function looks like the following:!

function untitledFunction(hypeDocument, element, event) { 
    alert('Hello World'); 
} 

You can edit the name of the function by editing the “untitledFunction” portion of the code or by editing the name 
in the Resource Library. JavaScript function names must not start with a number. Function code can only be inserted 
between the curly brackets. The portion (hypeDocument, element, event) is required and therefore not ed-
itable.!

JavaScript Documentation Viewer!
The Documentation Viewer below the editing area can be helpful for quickly building JavaScript functions based 

on API functions. Tumult Hype’s Documentation Viewer provides in-app documentation for all of Tumult Hype’s Java-
Script API functions, and also allows functions to be quickly inserted into the JavaScript editor. To insert any function:!

1. Place the editor’s cursor where you want the function to be inserted.!
2. Select the JavaScript function you wish to be inserted.!

3. Click the Insert button (� ) to the right of the function name.!
Functions can also be inserted by dragging-and-dropping them from the functions listing or by double-clicking 

their row.!

API Functions!
Tumult Hype offers many JavaScript APIs to control various aspects of a document. These APIs can be called 

both by JavaScript functions written within Tumult Hype, and by scripts external to the document.!

Document!
hypeDocument.documentName() 

Returns the name of the document. This value can be used in the global HYPE.documents[documentName].!
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hypeDocument.documentId() 
Returns the id of the container div for the document. This value can be used with document.getElementId() 

to retrieve the container element itself.!

hypeDocument.resourcesFolderURL() 
Returns the string value for the the document’s resources folder URL. Use this to reference assets added via the 

Resource Library.!

hypeDocument.functions() 
Returns an array of all user-defined JavaScript functions in the Tumult Hype Document.!

hypeDocument.getElementById(id) 
Searches the current document for the specified id (entered through the Identity inspector’s “Unique Element ID”) 

and returns the DOM HTML Element. This is similar to the typical document.getElementById, however the API 
version should be used instead as Tumult Hype may reassign ids in cases of collision.!

hypeDocument.relayoutIfNecessary(id) 
Explicitly tells the document to relayout all elements and groups for the current scene when using a flexible lay-

out. Use if you have externally changed the bounding size of the main container.!

Scenes!
hypeDocument.sceneNames() 

Returns a list of all scenes in the document.!

hypeDocument.currentSceneName() 
Returns the string value for the currently shown scene.!

hypeDocument.showSceneNamed(sceneName, optionalTransition) 
Changes to the specified scene. If optionalTransition is not specified it will default to the instant transition. 

See below for a list of valid transition constants.!

Note: Scene names are user-defined and uniqueness is not enforced. If you are going to use this function, be sure 
that no two scenes in any document have the same name.!

hypeDocument.showNextScene(optionalTransition) 
Shows the next scene, based on the order in the scene selector interface. If optionalTransition is not spec-

ified it will default to the instant transition. See below for a list of valid transition constants.!

hypeDocument.showPreviousScene(optionalTransition) 
Shows the previous scene, based on the order in the scene selector interface. If optionalTransition is not 

specified it will default to the instant transition. See below for a list of valid transition constants.!

Timelines!
hypeDocument.startTimelineNamed(‘timelineName’, direction) 

Starts the specified timeline at the beginning for the current scene. Note: timelines are user-defined, so they are 
not enforced to be unique. If you are going to use this function, be sure that no two timelines in any scene have the 
same name!!

Direction to play timeline:!

hypeDocument.kDirectionForward 
hypeDocument.kDirectionReverse 

Note: this function was named hypeDocument.playTimelineNamed(timelineName) in Tumult Hype 1.5 
and earlier.!

hypeDocument.pauseTimelineNamed('timelineName') 
Pauses the specified timeline for the current scene.!
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hypeDocument.continueTimelineNamed(‘timelineName’, direction) 
Continues the specified timeline in the direction specified where it left off for the current scene. Note: timelines 

are user-defined, so they are not enforced to be unique. If you are going to use this function, be sure that no two 
timelines in any scene have the same name!!

Direction to play timeline:!

hypeDocument.kDirectionForward 
hypeDocument.kDirectionReverse !
hypeDocument.goToTimeInTimelineNamed(timeInSeconds, 'timelineName') 

Jumps to a specific time in the specified timeline for the current scene.!

Note: Timeline names are user-defined and uniqueness is not enforced. If you are going to use these functions, be 
sure that no two timelines in any scene have the same name.!!
hypeDocument.currentTimeInTimelineNamed('timelineName') 

Returns the current time of the specified timeline in seconds.!

hypeDocument.durationForTimelineNamed('timelineName') 
Returns the duration of the specified timeline in seconds.!

hypeDocument.currentDirectionForTimelineNamed('timelineName') 
Returns the playback direction of the specified timeline. !

Possible return values:!

hypeDocument.kDirectionForward 
hypeDocument.kDirectionReverse !
hypeDocument.isPlayingTimelineNamed('timelineName') 

Returns true if the timeline is playing and false if it is not.!

Dragging!
JavaScript functions invoked by the On Drag handler can gather information about the current drag gesture.!

event['hypeGesturePhase'] 
When receiving a callback for the On Drag event with the Run Javascript… action the event object also offers 

information about whether the current drag gesture has just started or ended, was canceled, or the coordinates were 
updated. To get that state, access the hypeGesturePhase property in the event object:!

hypeDocument.kHypeGesturePhaseStart 
hypeDocument.kHypeGesturePhaseMove 
hypeDocument.kHypeGesturePhaseEnd 
hypeDocument.kHypeGesturePhaseCancel 
event['hypeGestureXPosition'] 

Returns the current x position of a drag when using the "On Drag" event with the "Run Javascript…" action.!

event['hypeGestureYPosition'] 
Returns the current y position of a drag when using the "On Drag" event with the "Run Javascript…" action.!

API Constants!
The only constants exposed are those for scene transitions:!
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hypeDocument.kSceneTransitionInstant 
hypeDocument.kSceneTransitionCrossfade 
hypeDocument.kSceneTransitionSwap 
hypeDocument.kSceneTransitionPushLeftToRight 
hypeDocument.kSceneTransitionPushRightToLeft 
hypeDocument.kSceneTransitionPushBottomToTop 
hypeDocument.kSceneTransitionPushTopToBottom 

Examples!
To show a scene named “Yellow” with the Instant transition style, this API function call would be used:!

hypeDocument.showSceneNamed('Yellow'); !
To show a specific scene named “Blue” from the JavaScript editor, using a Push Right to Left transition, and then 

play a timeline named “Robin” these function calls would be used:!

hypeDocument.showSceneNamed('Blue', kSceneTransitionPushRightToLeft); 
hypeDocument.playTimelineNamed('Robin'); 

Invoking API from outside of Tumult Hype!
To access the Tumult Hype API from a JavaScript outside of the embedded document, you can use the global 

Tumult Hype object:!

HYPE.documents[documentName] !
The document may not be an exact match for the filename. To figure out the value, you can look inside the ex-

ported Resources folder for the *_hype_generated_script.js file and find the document’s name there. You can also call 
the hypeDocument.documentName() function from within a JavaScript action to determine it.!

Events!
To help external JavaScripts integrate and interact with embedded documents Tumult Hype offers an event call-

back system, allowing external JavaScript functions to be triggered in response to events in embedded documents. At 
this time, four event callbacks are offered, so functions can be registered for document loading, scene loading and 
unloading, and timeline completion:!

HypeDocumentLoad 
HypeSceneLoad 
HypeSceneUnload 
HypeTimelineComplete 

The HypeTimelineComplete event also adds a name property to the event object, so you can determine 
which timeline raised the event.!

Register to receive these event callbacks by doing the following:!

window.HYPE_eventListeners.push({"type" : "HypeDocumentLoad", "callback" : 
myCallback}); 

Where HypeDocumentLoad is the event for which the callback should be triggered, and myCallback is the 
JavaScript function which should be invoked by the event.!
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Examples!
Visit Tumult Hype’s online documentation to see a demonstration of how external JavaScript can control a Hype 

document.!

To register a function to be run after an embedded Tumult Hype has been loaded:!

 <script> 
    function myCallback(hypeDocument, element, event) { 
        // display some data 
        alert("id: " + element.id + " type: " + event.type); 
 
        // show the next scene 
        hypeDocument.showSceneNamed('deux'); 
 
        // return false so it does not load the initial scene 
        return false; 
    } 
 
    if("HYPE_eventListeners" in window === false) { 
        window.HYPE_eventListeners = Array(); 
    } 
    w i n d o w . H Y P E _ e v e n t L i s t e n e r s . p u s h ( { " t y p e " : " H y p e D o c u m e n t L o a d " , 
"callback":myCallback}); 
</script> 

Note: Because the HYPE global variable may not be available immediately after HTML document has been loaded, 
this is the only reliable way to trigger external JavaScript functions in response to an embedded Tumult Hype docu-
ment being loaded. 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Inspectors!
Tumult Hype’s seven inspectors provide easy access to document, scene, and element properties, as well as a 

variety of other controls within Tumult Hype.!

Inspectors are accessible from the View menu, or by clicking the Inspector toolbar button. Document and Scene 
inspectors establish rules and settings for the document and scene. The Metrics, Element, Text, Mouse Action, and 
Identity inspectors become active when selecting one or more elements.!

Document Inspector!
The Document inspector provides many controls for initial document setup.!

• Document Size!
• Default Sizes – Contains many commonly used default docu-

ment sizes.!
• Width & Height – Control over the exact width and height of 

the document, in pixels.!
• Scale – Controls whether the document should scale horizon-

tally and/or vertically. When enabled, the controls offer the abili-
ty to specify how much of the containing window or div the 
Hype document should expand to fill. See the Flexible Layout 
chapter to learn more.!

• HTML Page Title – Defines the title of the exported HTML docu-
ment. By default, the title is the same as the exported file name.!

• Options!
• Show Loading Indicator – Controls the display of a loading 

indicator. When enabled, the Tumult Hype document will dis-
play “Loading…” as the document’s image resources are down-
loaded and cached. For tips on customizing the preloading 
screen, please read our support article on Custom Preloaders.!

• Draw Scene Backgrounds – When not selected, scene back-
grounds are transparent.!

• Use Webkit Graphics Acceleration – When selected, anima-
tions can use the system’s GPU when displayed in Webkit-
based browsers, which includes Safari, Mobile Safari, and 
Chrome. This almost always leads to better animation perfor-
mance, but some browsers or devices may have problems 
properly rendering accelerated content. If you see rendering 
problems, try deselecting this option.!

• Create offline application cache – When selected, Tumult 
Hype will generate a cache manifest file for resources used in 
your project. When loaded as a web app, your project down-
load all resources contained in the manifest file, and will work 
offline on subsequent launches.!

• Edit the Head HTML – Clicking this button opens an HTML editor, allowing the editing of the docu-
ment’s <head>. Any changes made to the document’s header are represented in Tumult Hype’s 
scene editor and are also included when the document is exported.!
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• Mobile Options!
• Viewport – Choosing Document Width sets the document’s viewport to match your document’s width. 

Device Width and Device Height define the exported document’s viewport to match the viewing 
screen’s width or height. Choosing Don’t Set excludes any viewport tag from your document’s export-
ed content.!

• Initial Scale 1.0 – Selecting this option adds the “initial-scale=1.0” property to the exported page’s 
viewport.!

• Allow user scaling – When selected, users can pinch and zoom to zoom in to and out of your docu-
ment.!

• User touch events – When selected, actions set in the Actions inspector default to tap events when 
possible. For example, a Mouse Click will be fired after a Tap without any delay.!

• Home screen web app – This option allows visitors to add your web app to their iOS device’s home 
screen.!

• Status bar – If “Home screen web app” is enabled, allows you to choose the desired appearance for 
your web app’s status bar.!

• Show Browser Compatibility Warnings – Warnings for browsers equal to or older than the selected 
version will be shown. Changing settings here will not affect document compatibility, only the warnings 
reported by Tumult Hype. Documents created with Tumult Hype always have the best possible compatibil-
ity with all browsers.!

!
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Scene Inspector!
The Scene inspector offers access to timeline settings, scene actions, and the background color of the scene. 

Please see the Scenes chapter for more information.!

• Animation Timelines – Displays the timelines on the current 
scene, their duration, and toggles whether timelines are relative 
or absolute. (Learn more about relative and absolute timelines.) 
Add timelines to the current scene by clicking the Plus button; 
remove them by clicking the Minus button. Rename timelines 
by double clicking on their name.!

• Background – Sets the background color of the current scene. 
Scene colors set on the first scene sets the background color of 
the exported .html file.!

• Scene Actions – Please see the Actions chapter for more in-
formation.!

!

Tumult Hype 2.5 Documentation! �                                                                                                                                   68

http://tumult.com/hype/documentation/scenes/
http://tumult.com/hype/documentation/timelines/#relativekeyframes
http://tumult.com/hype/documentation/actions/


Metrics Inspector!
The Metrics inspector controls size, content overflow behavior, place-

ment, and rotation properties of selected elements. While rotation, position, 
and scaling can all be manipulated directly in the scene area with mouse 
controls, this inspector offers fine tuning and may be more useful during 
multiple selection.!

• Content Overflow – Determines how text and inner elements is 
displayed when it goes beyond the bounds of the element, and 
whether a scroll bar should appear on elements which contain 
text that flows beyond the element’s area. The image on the right 
demonstrates how text flows within elements whose content 
overflow is set to Visible, Hidden, Scrollbars, and Auto Scroll-
bars.!

• Placement – Sets the exact height, width, and position for the 
selected elements. Selecting the Constrain Proportions check-
box ensures elements scale proportionally.!

• Flexible Layout – Selecting and deselecting the pins and scal-
ing arrows define how selected elements should behave as the 
exported Hype document is resized. For more information, 
please see the Flexible Layout chapter.!

• Scaling Behavior – Defines how elements should resize. In 
particular, offers control over how proportionally sized ele-
ments, like images, should be resized to preserve their as-
pect ratio.!

• Rotation – Sets the X, Y, and Z rotation angles. Negative val-
ues, like -180°, and values exceeding 360° are accepted. For 
example, to set a new rotation value for three full rotations clock-
wise, use 1080°.!

• Rotation follows motion path – When selected, element will rotate with the direction of a motion 
path. Rotation angles may be applied in addition to this setting.!

• Rotation Origin – Sets the X and Y offset percentages for the selected element’s rotation origin. !!
!
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Element Inspector!
The Element inspector contains stylistic properties for the selected 

element or elements.!

• Background Fill Style – Sets the background style as either 
an Image, Fill, Gradient, or None.!

• Gradients contain two colors and may be rotated.!
• Images may be scaled to fit the element, repeated horizon-

tally, or repeated vertically.!
• Borders – Creates a border with the selected style (None, Sol-

id, Double, Dotted, Dashed, Groove, Ridge, Inset, Outset) 
around the selected element. The border and radius of an ele-
ment’s four sides and corners can be set in this panel, as well 
as the color and style of the border. The padding setting con-
trols the distance between the border and the element.!

• Filter Effects – CSS3 filters perform a variety of powerful im-
age rendering effects.!

• Opacity – A value of 0% opacity sets selected elements as 
completely invisible. Note: An element with a 0% opacity will 
interfere with mouse actions on elements ordered below it in 
the scene. For an element to respond to mouse actions at a 
region in the document, it must not be covered by any other 
element, visible or invisible, at that point.!

• Reflection – This property creates a reflection of the selected 
element, with optional depth and offset values.!

• Shadow – Simulates a box shadow of the selected element, 
with settings for its color, position, and blur radius amount.!

Combining gradient, blur, and border radius properties on a box could 
produce an element like this:!

!
!
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Text Inspector!
The Text inspector controls text formatting including font selection, 

colors, alignment, shadows and spacing properties.!

By default, all fonts appear in the Font Family selection panel. The iOS 
font family option lists fonts installed on iOS devices. The Web option lists 
fonts installed on a majority of web browsers.!

� !

• Alignment – The text alignment of the selected elements.!
• Font – The Font Family, size and style of the selected ele-

ments.!
• Add More Fonts… – Loads the Google Fonts overlay to select 

fonts from Google's Font Directory.!
• Text Shadow – Sets a shadow for selected text with specified 

X, Y, blur radius, and color properties.!
• Text Spacing – Letter spacing defines the distance between 

characters, word spacing defines the distance between words, 
and line height sets the distance between individual lines.!

To add arbitrary HTML or CSS styles to a text element, edit its inner 
HTML by double clicking it and then clicking on the pencil icon which ap-
pears beneath the element.!
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For more information about Fonts, see the Fonts chapter.!

Actions Inspector!
The Cursor setting controls how the user’s cursor should appear when 

mousing over the selected element. Mouse actions are explained in the 
Actions chapter. These actions can be set on selected elements. As 
shown, multiple actions can trigger at one time. Setting any mouse action 
on an element automatically changes that element’s Cursor setting to 
Pointer.!

!
!
!
!
!
!
!
!
!
!
!
!
!
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Identity Inspector!
The identity inspector provides access to metadata for elements:!

• Alternate Text – Sets the alt tag for images and title tag for 
divs. Setting this value is useful for accessibility and for display-
ing tooltips.!

• Display Name – Sets the element’s name in the element list.!
• Unique Element ID – Sets element’s ID for accessing the ele-

ment directly in a custom function or JavaScript. Please see the 
JavaScript chapter for more details. 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Keyboard Shortcuts!
General!

Working with Elements!

Action Shortcut

Export document as HTML5 Command–Shift–E

Preview document in default browser Command–Return

Preview current scene in default browser Command–Option–Return

Zoom In Command–Right Angle Bracket (>)

Zoom Out Command–Left Angle Bracket (<)

Show Resource Library Command–Shift–L

Show Media Browser Command–Shift–M

Show Help menu Command–Shift–Question Mark (?)

Show and hide the Inspector Click Inspector in the Toolbar or Command–Shift–I

Show and hide the Colors window Click Colors in the Toolbar or Command–Shift–C

Show and hide the Toolbar Command–Option–T

Widescreen Layout Command–Shift–Backslash ( \ )

Action Shortcut

Move selected element by one pixel Arrow keys

Move selected element by 10 pixels Shift–Arrow keys

Add elements to (or remove them from) previously 
selected elements Command–click or Shift–click

Add range to (or remove it from) previously selected 
range Command–drag or Shift–drag

Constrain element movement to 45° angles Shift–drag
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Resize element Drag handle

Resize element from center Option–drag handle

Constrain aspect ratio when resizing element Shift–drag handle

Constrain aspect ratio when resizing element from center Shift–Option–drag handle

Rotate element Command–drag handle

Rotate element 45° Shift–Command–drag handle

Turn off alignment guides Command–drag

Duplicate selected element Command–D or hold down Option and drag

Paste with Animations Command–Option–V

Send element to the back Command–Shift–B

Send element one layer back Command–Shift–Option–B

Bring element to the front Command–Shift–F

Bring element one layer forward Command–Shift–Option–F

Group Command–Option–G

Ungroup Command–Shift–G

Indent Command–Right Bracket ( ] )

Outdent Command–Left Bracket ( [ )

Action Shortcut
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Working With Scenes!

Editing Keyframes!

Editing Animations!

Action Shortcut

Create new scene Command–Shift–N

Select next scene Command–Option–Right Arrow

Select previous scene Command–Option–Left Arrow

Delete selected scene
Show Scenes, click on desired scene, then press 
Command–Shift–Delete

Action Shortcut

Move selected keyframe forward one frame Right Arrow

Move selected keyframe backward one frame Left Arrow

Move selected keyframe forward 1 second Shift–Right Arrow

Move selected keyframe backward 1 second Shift–Left Arrow

Move selected keyframe to next keyframe in animation Up Arrow

Move selected keyframe to previous keyframe in 
animation Down Arrow

Move selected keyframe to next keyframe in timeline Shift–Up Arrow

Move selected keyframe to previous keyframe in timeline Shift–Down Arrow

Turn off keyframe and second marker snapping Command-drag

Action Shortcut

Toggle recording Command–R
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Set Capo Option–Command–K

! Move with Capo along with Playhead    
Hold down Control and drag either the Capo or the 
Playhead

! Move with Playhead to Next Frame    Command–Control–Right Arrow

! Move with Playhead to Previous Frame    Command–Control–Left Arrow

! Move with Playhead Forward 1s    Command–Shift–Control–Right Arrow

! Move with Playhead Backward 1s    Command–Shift–Control–Left Arrow

Play or stop and restart animation Space

Delete selected scene
Show Scenes, click on desired scene, then press 
Command–Shift–Delete

Next frame Command–Right Arrow

Previous frame Command–Left Arrow

Forward 1 Second Command–Shift–Right Arrow

Backward 1 Second Command–Shift–Left Arrow

Jump to Start Command–Shift–Option–Right Arrow

Jump to End Command–Shift–Option–Left Arrow

Jump to next keyframe in animation Command–Up Arrow

Jump to previous keyframe in animation Command–Down Arrow

Jump to next keyframe in timeline Command–Shift–Up Arrow

Jump to previous keyframe in animation Command–Shift–Down Arrow

Restart animation Home, or Function–Left Arrow

Loop playback Command–L

Action Shortcut
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Editing Motion Paths!

Using the Inspector!

Turn off keyframe and second marker snapping Command-drag

Action Shortcut

Action Shortcut

Add control points to (or remove them from) previously 
selected control points Command–click control point

Add selected point and all in-between points to the 
selected control points Shift–click control point

Convert a rounded control point into a corner control 
point Option–click control point

Constrain movement of control handles to 45° angles Shift–drag control handle

Keep control handles equidistant from control point Option–drag control handle

Move one control handle independent from its 
counterpart Command–drag control handle

Action Shortcut

Show the Document Inspector Command–1

Show the Scene Inspector Command–2

Show the Element Inspector Command–3

Show the Metrics Inspector Command–4

Show the Text Inspector Command–5 or Command–T

Show the Mouse Action Inspector Command–6
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Show the Identity Inspector Command–7

Action Shortcut
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Version History!
How to Update Tumult Hype!

Purchased through the Mac App Store!
If you purchased Tumult Hype through the Mac App Store, you can install the latest update by following these 

steps:!

1. Open the App Store by going to the Apple menu and selecting App Store!
2. Click the Updates tab at the top of the App Store window!
3. Tumult Hype should be listed in the Updates section, and clicking the Update button will install the latest 

update for free.!
If Tumult Hype isn’t listed in the Updates section, it’s either not installed at all or the latest version is already in-

stalled. If you are having issues, please try restarting your computer and signing out of the App Store application. 
Then, sign in again and check the Updates tab.!

Purchased through the Tumult Store!
If you purchased Tumult Hype through the Tumult Store, you can install the latest update by following these 

steps:!

1. Launch Tumult Hype!
2. Select the Check for Updates… menu item under the Hype menu!

Learn about purchasing Tumult Hype!

Tumult Hype Releases!
(Major releases are in bold)!
2.5.2 - March 26, 2014!
2.5.1 - February 18, 2014!
2.5.0 - January 27, 2014!
2.0.2 - November 14, 2013!
2.0.1 - September 30, 2013!
2.0.0 - August 20, 2013!
1.6.2 - April 9, 2013!
1.6.1 - February 12, 2013!
1.6.0 - January 7, 2013!
1.5.2 - September 20, 2012!
1.5.1 - May 9, 2012!
1.5.0 - February 23, 2012!
1.0.5 - September 1, 2011!
1.0.4 - August 7, 2011!
1.0.3 - June 14, 2011!
1.0.2 - May 31, 2011!
1.0.1 - May 27, 2011!
1.0.0 - May 20, 2011!
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Detailed Release Notes!

2.5.2 - March 26, 2014!
• Play once option for Animated GIF exports (no looping)!
• Improved proportional scaling behavior!
• Fixed an issue where auto-optimized images may have wrong colors and look incorrect with CSS filter 

effects!
• ‘Attach all documents’ button in feedback reporter!
• Fixed regression where ${resourcesFolderName} would not work with HTML Widgets!
• Better identification of SVG sizes when importing!
• Fixed issue where some audio files would hold up document loading in Chrome!
• Fixed issue where navigating back in Safari may not relayout a flexible page!
• Fixed a crash when exporting some documents as Video/Animated GIF!
• Partial fix for box shadows looking different in Hype vs. Safari!
• Localization tweaks!

2.5.1 - February 18, 2014!
• Transparent animated GIF exporting (via unchecking Draw Scene Backgrounds)!
• Fix issue where videos/iframes were incorrectly positioned in IE6-8!
• Border controls will now work in non-english localizations!
• On Swipe Right handler now exists in Italian localization!
• Export to video/animated GIF preview now displays in non-english localizations!
• Fix issue where swipe handlers could interfere with clicking on inner HTML content!
• API Change: event.type field for Swipes changed from HypeSwipeAction to HypeSwipeUpAction, Hy-

peSwipeDownAction, HypeSwipeLeftAction, HypeSwipeRightAction!
• Fixed frequent crashers!
• Center guides don't disappear anymore when rotating!
• Dragging action is now ended properly when ended outside of iFrame!
• Fixed timing function menu localization when animations with multiple timing functions are selected!
• Fixed issue where some animations do not play during the continue after drag control timeline!
• Change 'Constrain Proportions' to something sensible in German!
• Improved duration calculation for video/animated GIFs!
• Fixed issue where images/video/audio with the same name would be grouped together in the Resource 

Library!
• Fixed JavaScript error when swipe is cancelled!
• More intelligent about starting a timeline at the start to prevent infinite loops!
• Workaround for a Firefox bug where images could fade in and be slightly blurry then sharpen!

2.5.0 - January 29, 2014!
• Flexible layouts!
• Video and animated GIF export (OS X 10.7+ required for video)!
• French, German, and Chinese localizations!
• Anchor point for rotation!
• Reverse timeline playback!
• Scene transition duration control!
• Rotate 3D axes individually!
• Timeline playhead snapping!
• Capo now snaps on the timeline!
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• Move selected keyframes using the arrow keys!
• Go to next/previous keyframe menu item and keyboard shortcuts!
• Automatic optimization of images (resizing and compression)!
• Slots for Retina images in the Resource Library!
• JavaScript APIs for setting/getting timeline direction, getting the current time, getting a timeline’s playback 

state, getting a timeline’s duration, setting a scene transition’s duration, reversing playback, and relaying 
out a document!

• Pixel positions displayed when moving guides!
• Distribute Within Selection menu item!
• More clear indication of when recording!
• Group single objects!
• Timeline actions are always shown!
• Linen texture begone!!
• Exporting creates a restorable document file which can be loaded from the Help menu!
• Document inspector control to edit HTML page title!
• Anchor point snapping!
• Added a preset document size for Tumblr!
• Viewport initial-scale=1.0 option!
• Changed viewport options!
• A drag action is no longer cancelled if a second finger touches the screen!
• Changing relative timelines will mark the document as dirty!
• Deleting a completely blank scene does not warn about deletion!
• Opens scene selector when pasting scene!
• Fixed an errant audio warning when having wav and mp3 sources!
• Fixed 2.0.1 regression where you can only type one character at a time in the Resource Library search 

field!
• Selection box does not display if selection drag starts on a locked element!
• Scene size takes into account 3D rotated elements!
• Scene now allows selection of elements which were animated beyond the scene bounds!
• Fixed issue where scene may not be centered when resizing!
• Fixed issue in IE where background images could be sized wrong with padding!
• Fixed issue where padding would inset background images!
• Adding a border no longer offsets element!
• Feedback Reporter supports large files!
• Feedback Reporter attempts to resend on failure!
• Hitting return when in a text field in the inspector loses focus!
• Fixed issue where rotation selection handle could show up when it isn't supposed to!
• Fixed issue where playhead could be in wrong position when retiming animation!
• Can now move guides while editing text!
• Changing a scene name immediately changes the window title!
• Fixed issue where adding media to a group in the resource library would not be reflected in the inspector!
• Update files dialog cannot be resized too small!
• Motion paths always show animation segments even if they start/stop at the same spot!
• Improved export checkbox spacing!
• Prevents a 'Control Position' drag from moving elements off the scene!
• Videos will now always be added and autoplayed on the main timeline!
• Fixed issue with animating blurs jiggling!
• Can now get HypeSwipeAction event types in JavaScript!
• Tapping on a scene with a drag will no longer cause the drag to be fired!
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• Alphabetically sorts the JavaScripts in the 'Run JavaScript...' action popup!
• Tweaked look of timeline action bar!
• Fixed bug where hit area for motion path targets was too large when zoomed in!
• Improved audio context resource usage by our runtime!
• Fixed UI inconsistency of preview drop-down menu not acting like a dropdown!
• "Clear Recently Previewed Devices" is disabled if there were none!
• Reveal in Resource Library works better when there are groups!
• Fixed issue where elements below a hidden group weren't selectable!
• Fixed bug where tabbing out of the document size settings wouldn't show the "px" or "%" indicator!
• Fixed bug where editing the timecode view could change the color of an element!
• Fix crash when exporting a document with SVGs!
• Fix crash when reverting document!
• Dragging in a PDF now works correctly, and will be automatically optimized!
• Smoother rotation animations within Hype!
• Fixed issue where Inner HTML might display differently in Hype than in Exports!
• Using Command-Control-K to set Capo will turn on recording if it was off!
• Hardening against Resource Library corruption!
• Fixed bug where clicks in Chrome on Windows 8.1 would not register!
• Removed Retina versions of document size defaults since we better support Retina images!
• Fix some top crashes!
• Buttons with drag handlers will now exit the pressed state!
• Resource Library does not allow opening in external editor when using the Quick Look feature!
• Rotation now works correctly in IE 9!
• Fixed issue where a warning would incorrectly appear when making a motion path!
• Go to time will now more aggressively set properties from the timeline!
• Fixed regression where ${resourcesFolderName} was not being substituted in JavaScript!
• Fixed an issue where log file could grow too large!

• 2.0.2 - November 14, 2013!
• Fix audio not working on Firefox 25!
• Workaround for issue where iBooks would crash with audio by using HTML5 audio instead of the Web 

Audio API!
• Fix issue where a non-preloaded audio would require two taps to play on iOS!
• Fix issue where audio would not play in an ePub in iBooks on iOS!
• Rotation follows motion path now works on IE6-8!
• If "Draw scene backgrounds" is unchecked it will not set a document background color!
• Fix issue where scene does not fully transition out on scene unload!
• Fix an issue where Go to Time in Timeline may not work correctly!
• Fix issue where scrolling won't work if a mouse event is set!
• Does not show incorrect browser warning when having wav and mp3!
• Fix error when uploading documents via Feedback Reporter on 10.9!

2.0.1 - September 30, 2013!
• Fixed crashes!
• Cache manifest will now work when resources have spaces in their filename!
• Fixed bug where timelines would not run on scene unload!
• Fix exception when using custom fonts with IE 6-8!
• Typekit fonts will now preview within Hype if "localhost" is set on the kit as a valid server!
• Fixed bug where fonts would be duplicated when reverting document!
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• Quick Look preview properly shows multiple scenes!
• Fixed bug where elements would not move and rotate along path in Safari 5.1!
• Fixed bug where text alignment could be wrong in new text boxes!
• Fixed issue where QuickTime videos would not play in Chrome!
• Some motion paths animate more smoothly!
• Timelines triggered in the kHypeGesturePhaseEnd can animate properties from the drag timeline!
• Fixed HTML Widget positioning on Safari 6.1 and 7!
• Fixed a bug where videos with autoplay might not play at the right time!
• No longer draws non-animating segments in the timeline when motion paths are active!
• Documentation viewer has the right URL for gestures!
• Fixed issue where edited text would jump to the bottom when adding a font!
• Fixed regression where SVGs could not be replaced with SVGs in the Resource Library!
• Fixed bug where scrolling would be off after expanding a group in the timeline view!
• Fixed bug where play sound timeline action would be pre-populated with last action!
• Fixed issue reverting with certain head HTML!
• Editing Head HTML now marks a document as dirty!
• Reverting Head HTML now works correctly!
• Fixed bug where selection halo may be incorrect when using motion paths!
• Fixed bug when scrollbars may not appear correctly when toggling system display preference!
• Fixed typo mentioning "Hype Preview" instead of "Hype Reflect"!
• Disable "Use touch events" in the document inspector when no documents are active!
• Better undo menu naming for motion path operations!!

2.0.0 - August 20, 2013!
For more details and a tutorial video, please see What’s New In Tumult Hype 2.0.!

• Instant previews to iOS with Hype Reflect!
• Audio actions!
• Curved Motion Paths!
• Google Fonts and custom web fonts!
• Scene-level Swipe left/right/up/down events!
• Element and scene-level drag events!
• Touch and tap handlers joined with mouse action handlers!
• iOS web app support!
• Option to hide iOS location bar on page load!
• Option to prevent iOS tap highlighting!
• Support for offline web content using cache manifest file!
• Preview toolbar button now offers a list of all browsers and devices running Hype Reflect!
• Search engine support with option to export text contents!
• Added two new shapes — circle and rounded rectangle!
• Renamed "Box" to Rectangle for consistency!
• Quick Look support!
• Full Screen support!
• Spotlight support!
• Introduced a new JavaScript API to get the id of the exported document’s container div: hypeDocumen-
t.documentId()!

• Double clicking a function’s or variable’s row in the documentation viewer inserts the function or variable!
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• Added a View > Center on Scene command, to quickly center Tumult Hype’s scene editor on the scene 
itself!

• Better rotation control in Metrics inspector which now handles counter-clockwise rotation in addition to 
clockwise.!

• Multiple elements can now be rotated in the scene editor by selecting multiple elements and Command-
dragging on a selected element’s corner resize handle!

• Support for Opera 15!
• Browser compatibility data has been updated for the latest browsers!
• iOS 5’s Safari is now the minimum browser for Mobile Safari warnings!
• By default, only common browsers will be shown as choices in preview menus; this behavior can be tog-

gled by a new “Only show recommended browsers in preview menu” option in Tumult Hype’s preferences!
• Scene transitions have been completely rewritten; the new system avoids gaps in Push transitions and all 

transitions are now more consistent across browsers!
• Unlicensed copies of Tumult Hype 2.0 warn about upgrading when opening 1.x documents!
• Anonymous usage reporting has been enabled; data is only submitted if the user has explicitly agreed!
• Tumult Hype 2’s “bundle identifier” has been changed from com.tumult.Hype to com.tumult.Hype2!
• Fixed many common crashes!
• Resolved issue where YouTube videos would not display properly or work with iBooks Author documents!
• Insulates custom JavaScript so if there are errors it won't interfere with the timeline!
• Pressing Enter while completing kanji no longer clears the text in inner HTML editor!
• Transparent PNGs now work on IE 6, and no longer render incorrectly on IE 7!
• Custom keyboard shortcuts broken on Lion when sandboxed (must quit and relaunch for custom keyboard 

shortcut changes to be noticed)!
• The Brightness CSS Filter now works properly in Chrome!
• Fixed bug where CSS3 Filter Effect Brightness could be applied incorrectly when using Safari Seed!
• Guide creator dialog is incorrectly sized on first open!
• Now scrolls to the appropriate item after choosing Reveal in Resource Library!
• Animated GIFs now animate in documents that have been exported to Dropbox!
• CSS Filter Effect controls have been moved to the bottom of the Element inspector!
• The Media Browser is better behaved with multiple spaces, and with Full Screen!
• Warn that TIFF and PSD images don’t render in most browsers!
• No longer incorrectly warn that iBooks doesn’t support CSS Filters!
• No longer incorrectly warn about video incompatibilities for image elements!
• Video warnings now have a correct category warning!
• Mouse events work properly in IE 9 when the document is in “quirks mode”!
• Opacity is now animated under IE 9 when the document is in “quirks mode”!
• Fixed an issue where setting and unsetting the blur CSS Filter Effect would cause images to remain blurry!
• Buttons without a fill, with no background image, or with a transparent fill color now behave properly on IE 

6 through IE 8!
• No longer incorrectly warn about SVG incompatibility with IE 9!
• Prevent videos from being replaced with images, and vice versa!
• Fixed a case where a text element’s background color would be drawn outside of the element’s bounds!
• Fixed a case where non-left aligned text elements could resize incorrectly on their first edit!
• Fixed a case where the element rotation cursor may be shown at inappropriate times!
• Fix assorted cases where text elements' content could appear differently in the scene editor vs. the pre-

viewed or exported document.!
• Fix case where replacing an image would not update proportion constraints for proper resizing.!
• Fix possible crash when opening certain malformed documents.!

Tumult Hype 2.5 Documentation! �                                                                                                                                   85



• Fix case where documents with more than 99 HTML widgets would not properly export HTML widgets 
after the 99th.!

• Ensure selected element lock state does not interfere with timeline or scene actions.!
• Harden the scene editor against margin and border style changes in document head.!
• Underline menu item state incorrectly and behavior broken if Text inspector active.!
• Fixed launch-time logs seen on 10.6!
• Fixed an issue where iFrames could be incorrectly exported!
• Fixed an issue where images pasted into a document would have their size reported as 0b in the Re-

source Library!
• Fixed an issue where new text boxes could display the wrong font in Internet Explorer 8!
• Absolute timelines with one keyframe now apply keyframe’s value changes!
• Improve document state restoration behavior!
• Text background gradients now appear in Safari and Chrome!
• Fix issue for rotated gradients in IE 10!
• Better check for and warn about possible permissions errors when exporting while sandboxed!
• Fix for buttons not showing pressed state on mobile devices!
• Export errors correctly propagated when exporting fails!
• Support scene scrolling when dragging or resizing an element past visible scene bounds when full 

screened!
• Many other small improvements, bug fixes, and polish!

1.6.2 - April 9, 2013!
• Developer News window for critical information!
• Fixed regression where black outline can appear around PNGs in IE7-8!
• Gradients in IE 10 will be rotated properly!
• Workaround for Mac App Sandboxing bug of keyboard shortcuts not working on Mac OS X 10.7!
• Resolved issue with Mac OS X 10.7-10.7.2 where resources may not behave correctly!
• Warn when hitting Mac App Sandboxing bug that appears as a permissions error!
• Prompt to update when opening a document created with a newer version of Tumult Hype!
• Fix a crasher when opening documents!
• Mouse events work properly in IE 9 when the document is in “quirks mode”!
• Opacity is now animated under IE 9 when the document is in “quirks mode”!

1.6.1 - February 12, 2013!
• Changed ".resources" export folder name to ".hyperesources" to prevent problems displaying on older 

Microsoft IIS web servers (such as those used by GoDaddy)!
• Fixed bug where Chrome or Safari may not animate or show trails when elements have a blur!
• Fixed crash when playing and moving animation at the same time!
• Fixed regression where Go To URL would open inside of iframes!
• Command-clicking to rotate will now work when zoomed out!
• Resolved crash on older versions of Mac OS X 10.7!
• Fixed issue where some users could not preview in Chrome!
• Does not show window outline when using multiple desktops/mission control!
• Fixed regression where Go To URL would not work on IE9 and Opera in some cases!
• Deleted resources will not be exported!
• 'Edit Head HTML...' button is properly disabled when there are no open documents!
• Workaround sandboxing issue where we may not always know preview browser versions!
• Undoing/redoing "Include in document <head>" displays code in head correctly!
• Fixed issue iPhone Simulator would not work for previews!
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• Workaround iBooks Author bug where videos would not display if they contain certain characters!
• Fixed bug where Resource Library may appear blank!
• Fixed issue where a final timeline action may not always get triggered!
• Stacks of keyframes now draws relative keyframes properly rounded!
• JavaScript documentation updates!

1.6.0 - January 7, 2013!
For more details and a tutorial video, please see What's New In Tumult Hype 1.6.!

• Support for CSS Filter Effects (requires Safari 6 to be installed)!
• Resource Library for managing images, videos, functions, and document assets!
• Capo: create arbitrary animation start times!
• Layout guides to a scene in bulk, defining either a distance between or a number of guides!
• Retina artwork and icons in the application!
• Tumult Hype is now Sandboxed!
• New actions to pause, continue, and jump to specific times!
• Timeline Actions which can be triggered at any point on the timeline!
• Action chaining to make sophisticated flows!
• The document’s HTML <head> contents can now be modified!
• Preloading of images can now be toggled via the Resource Library!
• Support for IE10 3D transforms and gradients!
• More iOS-supported fonts in the font panel!
• Timelines can now be set to have absolute or relative initial keyframes!
• Absolute keyframes, rather than relative keyframes, are now the default for new timelines!
• Reduce HYPE.js size to 38.08 KB (279 bytes less than 1.5.2!)!
• API Documentation Viewer for Javascript and <head> editors!
• Syntax highlighting for Javascript and CSS within HTML!
• JavaScript APIs for starting, pausing, and continuing timelines, as well as jumping to a specific time on a 

timeline!
• JavaScript API for invoking custom JavaScript functions written in Tumult Hype!
• JavaScript API for getting the URL of the document’s associated resources folder!
• Added event.timelineName property to the On Animation Complete javascript callback to determine which 

was completed!
• External scripts can now register for callbacks on HypeDocumentLoad/HypeSceneLoad/ 

HypeSceneUnload/HypeTimelineComplete events!
• Identical Tumult Hype documents can now be loaded in the same HTML page!
• Find/Replace support for Tumult Hype’s JavaScript editor!
• Indent/Outdent keyboard shortcuts for JavaScript editing!
• Browser warnings are now defined by a minimum version number or ‘none’, rather than discrete check-

boxes, per browser!
• Rotate elements on their z-axis by command clicking on a corner resize point and dragging!
• With multiple elements selected, resizing one will proportionally resize all other selected elements!
• Option to enable/disable webkit graphics acceleration in Document Inspector!
• Generates iBooks Author/Dashboard widget thumbnail from the current scene and time!
• Generates retina @2x thumbnails for iBooks Author/Dashboard widgets!
• Browser compatibility warnings for iBooks 3!
• Show and hide user created guides!
• Command-clicking lock/visibility will toggle all, option-clicking will toggle others!
• Previews are now handled via a built-in server, rather than via exported files!
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• During editing, text elements now respect the selected text’s justification when resizing (e.g. right justified 
text will cause the text element to resize from the left)!

• Pressing the Escape key while editing an element will end editing!
• Keyframes can now be stacked, when animations overlap on the timeline and represents an instant transi-

tion!
• Multiple animations or keyframes can be selected via shift clicking!
• Way to have extended trials!
• “Play Timeline” action has been renamed to “Start Timeline”!
• “On Animation Complete” has been renamed to “On Timeline Complete”!
• “Use Vertical Layout” has been renamed to “Widescreen Layout”!
• Document resource folder name is now “documentName”.resources rather than “documentName”_Re-

sources!
• Show Guides menu item is now in the Arrange > Guides submenu!
• Arrange > Align menu items have been renamed and rearranged for clarity!
• Added document sizes for iPad 3 and iPhone 5!
• Does not have the “Build with Hype” watermark enabled by default!
• The “Built With Hype” now opens http://tumult.com/hype/ in a new browser window!
• Fixed nasty bug where resources might go missing!
• IE 10 and other current browser compatibility updates!
• Aliases to images and videos are now resolved to the source file when added to a document!
• Animation segments in the element list can now be resized such that all associated animations are re-

versed!
• Changes made in the inspector are now applied before changing scenes!
• Documents with a ‘.’ in their name will now preview with the correct name!
• Documents with a space at the end of their file name can now be uploaded to Dropbox!
• Duplicating an element nested in a group will create the new element in the same group!
• Elements with invalid origins or sizes will no longer prevent documents from being edited!
• Elements with zero width and/or height are better handled!
• Fixed a case where the selected element may not be highlighted in the element list!
• Fixed issue causing text elements to wrap when being edited near the scene bounds!
• Fixed issue where button states could be displayed incorrectly!
• Fixed issue where guides would always be locked even if no guides are present, preventing any new 

guides from being added!
• Fixed issue where identically named timelines would prevent any timeline other than the first such named 

timeline from being edited!
• Fixed issue where moving elements into or out of groups could lead to incorrect z-ordering!
• Fixed issue where playing the main timeline on scene load could lead to issues when transitioning to other 

scenes!
• Fixed issue where pressing the spacebar while editing an HTML Widget would play or pause playback 

rather than insert a space!
• Fixed issue where scene would not properly update if an edited element’s text scrolled past the bottom of 

the visible window!
• Fixed issue where the Format > Font > Bigger/Smaller might not have any effect!
• Fixed issue where videos could be incorrectly positioned on IE 8 and earlier!
• Fixed issues where Inspector could take focus, losing changes to text elements, or preventing keyboard 

commands (such as playing and pausing using the space bar) from being honored by the scene editor!
• Fixed some cases where images would flicker after a scene change on Chrome and Safari 6!
• Fixed some cases where the scene border would be drawn incorrectly after launching Tumult Hype!
• Generate Dashboard and iBooks Author Widget thumbnails at the correct pixel size!
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• Tumult Hype quits more quickly!
• Shows reflections during scene transitions!
• Scene selector will no longer have focus after a change has been made!
• Fix issue where the scene would redraw/flicker when recording animations!
• Properly preserve nesting when making groups!
• Fixed issue where pasted text would wrongly resize together!
• Does not allow elements/groups in hidden groups to be selected!
• Fixed bug where undo would not work correctly when moving keyframes!
• Trebuchet MS will now display in Firefox and IE!
• Do not allow timing functions to change on locked elements!
• Properly sandbox margin-left for li in CSS Reset!
• IE6-8 video elements (using quicktime plugin) will pause on scene unload!
• Fixed several crashers!
• Does not warn about text-shadow for IE10 as it supports it!
• Fixed bug where grouped elements will look bad on Retina macs within Tumult Hype!
• Fixed bug where ‘open in window’ would not work on iOS webapps!
• Fix bug where animations can be resized to a time less than zero!
• Command-clicking on links will now open in a new tab for some browsers!
• Correctly use iBooks Author document sizes!
• Better warning for iOS 6 autoplaying!
• Improved guideline hit detection and snapping for cases when many guides are close together!
• Improved timeline resize behavior when moving keyframes or animation segments at the end of the time-

line!
• It’s now possible to undo the deletion of video elements with multiple sources!
• Line height can now always be modified, even if the element already has multiple line heights defined!
• Made element resize handles easier to click and drag!
• Many issues around dragging multiple animations and/or keyframes have been resolved!
• New documents respect ruler visibility changes made with earlier documents!
• Pasting content when a button is in a state other than “Normal” now works properly!
• Popovers are now dismissed when their associated document window is closed!
• Removing all guides will now remove guides that covered each other!
• Resizing proportionally constrained elements past scene bounds no longer causes erratic element move-

ment!
• Text Spacing can now be set back to “Auto” after having been set to a different value!
• Text shadow offsets can now have negative values!
• The loop button’s state is now properly preserved after changing scenes!
• The playhead will now remain visible when moved with keyboard shortcuts, even if it moves beyond the 

timeline’s current visible bounds!
• When resizing an element nested in a group, resize guides are now drawn correctly!
• Many top crashes have been fixed!

1.5.2 - September 20, 2012!
• Mountain Lion minor fixes!
• Command-clicking lock/visibility will toggle all, option-clicking will toggle others!
• Added event.timelineName property to the On Animation Complete javascript callback to determine which 

was completed!
• Workaround for issue where Chrome and now Safari 6 images would flicker when using Dropbox!
• Improved element placement on IE6-8!
• Fixed issues where z-index may be incorrect inside groups!
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• Improved scrolling on iOS for the HTML Widget!
• Fixed top crasher that could occur when closing documents with videos!
• Fixed an 1.5.0 regression where button states might display incorrectly!
• Fixed an issue where a crash could occur when resizing the document!
• Updated to latest Dropbox SDK which handles /public folder deprecation!
• Properly generates thumbnail images on Retina Macs for iBooks Author!
• Hang reporting mechanism!
• Better focus behavior for the inspector!
• Quits faster!
• Fixes issue where sometimes the spacebar could not be used to pause!
• Better handles adding alias files!
• Keyboard shortcuts for moving playhead will also scroll the view when necessary!
• Improved ability to resize/move animations near the end of the timeline!
• Fixed issue where duplicating an element in a group would make the duplicate outside the group!
• Fixed issue where playing the main timeline on scene load could lead to wonkiness when transitioning to 

other scenes!
• Does not show the iframe border in IE7-8!

1.5.1 - May 9, 2012!
• Copy/Paste Scenes!
• Option-clicking the keyframe button will add keyframes for every visible property on selected elements!
• Attachments can now be added to feedback reporter!
• Fixed issue where rotated elements would not show up correctly in IE!
• Restored v1.0.x’s rotateY(0deg) trick for performance improvements!
• Fixed issue where scenes might not be able to be duplicated!
• Animations in groups are now pasted correctly!
• Fixed bug where overlapping elements might not be able to move!
• Fixed issue where 0px by 0px elements (like audio) would eat mouse selection!
• Faster loading on IE9 for documents with lots of images!
• Fixed issue where jQuery could interfere with Tumult Hype animations!
• Reverting will correctly revert open JavaScripts!
• Fixed issue where scrollbars could not be dragged when ruler is visible!
• Resolved issue where locked guides would not allow elements to be moved!
• Fixed issue where double-clicking rulers would change the document layout!
• Locking disallows mouse action manipulation!
• Fixed issue where swap transitions would show elements outside of scene!
• Fixed issue where missing fonts could lead to not being able to edit Javascript/InnerHTML!

1.5.0 - February 23, 2012!
For more details and a tutorial video, please see What’s New In Tumult Hype 1.5.!

• Redesigned animation interface separating element and keyframe editing!
• Grouping!
• Scene zooming!
• Element locking and visibility toggles!
• Improved Lion support (Versions, Autosave, Scrolling)!
• ‘Export as HTML5 > Dashboard/iBooks Author Widget’!
• Rulers!
• Custom Guidelines!
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• “Paste with Animations” for element copying!
• Bounce and instant animation timing functions!
• Insert “HTML Widget” for arbitrary code/script execution!
• Exported Javascript is significantly smaller (generally 1/3 the size of 1.0.5; a minimal document only re-

quires 41 KB download)!
• New app icon!
• Can change window layout to have vertical timelines on the right!
• Accurate motion paths when selecting elements!
• Hex color picker!
• Compose email action!
• Context menus throughout the application!
• Improved selection behavior so selections made in the element list are preserved!
• 3D support for Firefox 10!
• Updated supported browser list/warnings!
• Selection colors better show which view is active!
• Relative element spacing and sizing snapping!
• Editable Timecode/Go to Time (command-shift-t)!
• Ability to set your own ids on elements!
• Custom javascript functions now get the triggering event!
• Easier to adjust items at the end of a timeline!
• Document default sizes for mobile banner ads, iPhone retina displays, and iBooks Author Widgets!
• Playhead does not cover timeline (ticks reversed)!
• Malformed javascript no longer kills the page!
• hypeDocument.getElementById() API added!
• Can run <script> if there’s no source in innerHTML!
• Top-level HYPE object is now versioned to avoid conflicts!
• Adopted window.requestAnimationFrame for better browser performance!
• Push and Crossfade scene transitions for more browsers!
• Context menu item to refresh inner html content!
• Rearranged menu items (preview is now in the File menu)!
• New keyboard shortcuts for exporting, animation navigation!
• Fixed issue where Save/Save As would not work complaining “File exists”!
• Worked around IE issue where IE6 would report “Stack Overflow on Line 0”!
• Worked around Safari issue where rotated elements would not be animated correctly!
• Worked around Safari issue where full screen videos would not display properly!
• Fix issue where background color for elements may be unable to be changed!
• Fixed issue where the color picker’s colors would not match!
• Removed CSS3 Transitions and forced hardware compositing!
• Resource tracking is better about notifying for changes on launch!
• Fixed bug where the spacebar would sometimes stop working for playing!
• Worked around IE issue where it doesn’t always capture mouse events when background fill style is none!
• Fixed issue where videos could appear blank!
• Less renaming (Image-1, Image-2) of resources!
• Fixed console warnings in Firefox about parentElement!
• If an image is changed outside of Tumult Hype and then adopted, the “original size” value is now updated!
• Scene duplication will add a scene after the currently selected scene!
• Fix issue where mouseout events could happen from the wrong scene!
• Original width/height now update when choosing a new background image!
• Properly updates element position when changing timing functions!
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• Workaround potential issue where timecode view font can’t load!
• Fixed bug where element may not rotate in exported version if rotation animation was copied to the ele-

ment!
• Fixed bug where playTimeline() API would not work on scene load!
• Disable Mac OS X’s automatic text substitutions!
• Fixed graphics glitch when scrolling javascript on Lion!
• Fixed issues with scene thumbnail drawing!
• Fixed issue where Inner HTML editor may disappear!
• Fixed issue where animation configuration might not be displayed on screen!
• Fixed issue where deleting the last bracket in a function would not let you add it back!
• Fixed issue where content was not completely sandboxed from rest of page in Firefox!
• Fixed issue where button may not show accurately on different timelines!
• Fixed issue where a text shadow of 0px 0px was still showing a small shadow!
• Fixed issue where changing scenes during a scene change could lead to the wrong/blank scene!
• Fixed issue where items could be randomly selected after deleting elements!
• Fixed bug where animation popover would be in the wrong place after a scroll!
• Fixed data loss where changing a timeline would discard inner html edits!
• Fixed issue where export warning dialog window could be improperly sized!
• Fixed issue where editing javascript did not reflect in the document being modified!
• Fixed issue where editing the animation timing function did not reflect in the document being modified!
• Improved timeline execution performance!
• Fixed issue where feedback reporter dialog would be on top of other application windows!
• Fixed feedback reporter window sizing issues!
• Fixed bug where text spacing controls would show fractions!
• Fixed element placement!
• Removed print toolbar button!
• Fixed bug where the preference pane may be highlighting the wrong view!
• Fix issue where saving a document while editing inner html would not result in the inner html being saved!
• Many performance improvements!
• Fixed other crashers!

1.0.5 - September 1, 2011!
• Fixed 1.0.4 regression where key action handlers could cause the document to be blank on export!
• More Lion Fixes!
• Resolved issue where video elements could appear blank on launch!
• Fixed issue where border stroke colors might not be set properly!
• Fixed bug where dragging and dropping in the element list could result in the wrong z-index!
• Better support for special characters in resources!

1.0.4 - August 7, 2011!
• 14-day full trial support!
• Non Mac App Store purchasing option!
• Radial snapping when holding the shift key while dragging!
• Fixed color picker glitches for background color with HSV/CMYK/different profiles!
• Copy/Pasting preserves z-ordering of elements!
• Fix some cases where resources aren’t being deleted!
• Fix issue where button images could get stuck in the hover state for IE!
• Fixed issue where rotation would be offset in IE 6-8!
• Fixed issue where video would sometimes not play on IE 6-8!
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• Duplicating a scene will duplicate scene actions!
• Force utilizing hardware acceleration!
• Setting an image in the element inspector will unset the background color!
• Faster performance and less jittering when playing back with large elements!
• Lion fixes!
• Open URL… action now will break out of iframes!
• Performance improvements when opening/previewing large documents!
• Fixed issue where element editor could be shown over JavaScripts!
• Fix issue where X or Y rotations could cause Z rotations in Firefox!
• Do not allow interaction with iframes in the scene editor!
• Fixed crasher when playing or changing scenes and closing the document!
• Shows warnings for scene actions!
• Fixed issue where changing shadow color could also change text color!
• Workaround for all text not being selected when entering edit mode with Safari 5.1!
• Updated to latest iMedia Browser Framework!
• Resolved issue where HYPE.js could be loaded multiple times!
• Removed border from iframe CSS reset!
• HYPE.documents properly lists all Tumult Hype embeds on the page!
• Fixed issue where key press handlers would not be removed!
• Re-initialize dropbox sheet for each export!
• Fix issue where documents would not save if a timeline was undone!
• Fixed Lion scroller issue!
• Fix issue where public API doesn’t expose kSceneTransitionPushRightToLeft!
• CSS Resets background-color appropriately!
• Does not allow editing before “function” in JavaScripts!
• Faster export time if warnings are turned off!
• Many other misc. fixes!

1.0.3 - June 14, 2011!
• Implemented Revert to Saved!
• Fixed issue where buttons could not be clicked on their text!
• Fixed issue with images not working in iframes for IE/Firefox only!
• PNGs in IE look much better!
• Fixed crash/hang when trying to look for resources on unreachable servers!
• Fixed issue where some characters could cause parse errors for the JSON!
• Fixed issue where negative widths/heights could cause animation to behave unexpectedly!
• Fixed issue not being able to duplicate scenes from an older version!
• Fixed issue where timelines could not run at scene load/unload time!
• Fixed issue where Dreamweaver could kill Tumult Hype’s output!
• If text is 100% opaque, don’t use alpha filter so it looks better in IE!
• Remove shadow and reflection if not actually used!
• Remove mouse actions if not actually used!
• Fix video on next big cat!

1.0.2 - May 31, 2011!
• Show “Built with Hype” can additionally be found in general preferences!
• Fixed regression saving when duplicating scenes without animations!
• Fixed issues with the next big cat!
• Fixed color picker issue where colors won’t apply!
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• Fixed crash on close for the feedback reporter!
• Other misc. fixes!

1.0.1 - May 27, 2011!
• Easier separation between HTML and Resources (you only need to edit the script tag’s src in the HTML)!
• Fixed issue where the preview/export could be blank!
• Fixed issue with deleting duplicated scenes using buttons!
• Fixed issue preventing Tumult Hype documents from being embedded in iframes!
• Fixed text shadows not always showing up for buttons!

1.0.0 - May 20, 2011!
• Initial Release!
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